ramips: Add support for ZTE ZXECS EBG3130 aka BDCOM WAP2100-SK
[openwrt/openwrt.git] / include / unpack.mk
index 3fabf460336b711a8e413927c901c8a581a7eb46..a139827490f53b063a424ab0029ae7580fe7f409 100644 (file)
@@ -5,14 +5,9 @@
 # See /LICENSE for more information.
 #
 
 # See /LICENSE for more information.
 #
 
-# unpacking files with +s may break on some platforms. this typically emits error code 2
-ifneq ($(HOST_OS),Linux)
-  HOST_TAR:=trapret 2 $(TAR)
-else
-  HOST_TAR:=$(TAR)
-endif
+HOST_TAR:=$(TAR)
 TAR_CMD=$(HOST_TAR) -C $(1)/.. $(TAR_OPTIONS)
 TAR_CMD=$(HOST_TAR) -C $(1)/.. $(TAR_OPTIONS)
-UNZIP_CMD=unzip -d $(1)/.. $(DL_DIR)/$(PKG_SOURCE)
+UNZIP_CMD=unzip -q -d $(1)/.. $(DL_DIR)/$(PKG_SOURCE)
 
 ifeq ($(PKG_SOURCE),)
   PKG_UNPACK ?= true
 
 ifeq ($(PKG_SOURCE),)
   PKG_UNPACK ?= true