Add the generic PWM api from Bill Gatliff (experimental). Ignore the leds trigger...
[openwrt/openwrt.git] / include / verbose.mk
index f18e9a2c7105257a7993f284b2220ea548e4280d..9fe27ced52f1324adcfba16cdb84d50f65c3089b 100644 (file)
@@ -4,13 +4,10 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id:$
 
 ifeq ($(NO_TRACE_MAKE),)
 NO_TRACE_MAKE := $(MAKE) V=99
-SUBMAKE := $(MAKE)
 export NO_TRACE_MAKE
-export SUBMAKE
 endif
 
 ifndef KBUILD_VERBOSE
@@ -21,15 +18,17 @@ ifeq ("$(origin V)", "command line")
 endif
 
 ifeq ($(IS_TTY),1)
-  _Y:="\\033[33m" # yellow
-  _N:="\\033[m" #normal
+  ifneq ($(strip $(NO_COLOR)),1)
+    _Y:=\\033[33m
+    _N:=\\033[m
+  endif
 endif
 
-define MESSAGE
-       echo -e "$(_Y)$(1)$(_N)" >&3
-endef
-
 ifneq ($(KBUILD_VERBOSE),99)
+  define MESSAGE
+       printf "$(_Y)%s$(_N)\n" "$(1)" >&8
+  endef
+
   ifeq ($(QUIET),1)
     ifneq ($(CURDIR),$(TOPDIR))
       _DIR:=$(patsubst $(TOPDIR)/%,%,${CURDIR})
@@ -37,15 +36,23 @@ ifneq ($(KBUILD_VERBOSE),99)
       _DIR:=
     endif
     _NULL:=$(if $(MAKECMDGOALS),$(shell \
-               $(call MESSAGE, "make[$(MAKELEVEL)]$(if $(_DIR), -C $(_DIR)) $(MAKECMDGOALS)"); \
+               $(call MESSAGE, make[$(MAKELEVEL)]$(if $(_DIR), -C $(_DIR)) $(MAKECMDGOALS)); \
     ))
+    SUBMAKE=$(MAKE)
   else
     ifeq ($(KBUILD_VERBOSE),0)
-      MAKE:=&>/dev/null $(MAKE)
+      SILENT:=>/dev/null 2>&1
+    else
+      SILENT:=
     endif
     export QUIET:=1
-    MAKE:=cmd() { $(MAKE) $$* || {  echo "make $$*: build failed. Please re-run make with V=99 to see what's going on"; false; } } 3>&1 4>&2; cmd
+    SUBMAKE=cmd() { $(SILENT) $(MAKE) -s $$* < /dev/null || { echo "make $$*: build failed. Please re-run make with V=99 to see what's going on"; false; } } 8>&1 9>&2; cmd
   endif
 
   .SILENT: $(MAKECMDGOALS)
+else
+  SUBMAKE=$(MAKE) -w
+  define MESSAGE
+    printf "%s\n" "$(1)"
+  endef
 endif