kernel: bump 4.9 to 4.9.155
[openwrt/openwrt.git] / include / version.mk
index 6c6eb75ff66d2e6209648673cc7e89c8b79b162f..8ef0a7e65efda40401447e6caedfc6b2045fdd47 100644 (file)
@@ -11,6 +11,7 @@
 # SOURCE_DATE_EPOCH:=x
 
 PKG_CONFIG_DEPENDS += \
+       CONFIG_VERSION_HOME_URL \
        CONFIG_VERSION_BUG_URL \
        CONFIG_VERSION_NUMBER \
        CONFIG_VERSION_CODE \
@@ -31,7 +32,7 @@ VERSION_CODE:=$(call qstrip,$(CONFIG_VERSION_CODE))
 VERSION_CODE:=$(if $(VERSION_CODE),$(VERSION_CODE),$(REVISION))
 
 VERSION_REPO:=$(call qstrip,$(CONFIG_VERSION_REPO))
-VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.lede-project.org/snapshots)
+VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.openwrt.org/snapshots)
 
 VERSION_DIST:=$(call qstrip,$(CONFIG_VERSION_DIST))
 VERSION_DIST:=$(if $(VERSION_DIST),$(VERSION_DIST),OpenWrt)
@@ -41,10 +42,13 @@ VERSION_MANUFACTURER:=$(call qstrip,$(CONFIG_VERSION_MANUFACTURER))
 VERSION_MANUFACTURER:=$(if $(VERSION_MANUFACTURER),$(VERSION_MANUFACTURER),OpenWrt)
 
 VERSION_MANUFACTURER_URL:=$(call qstrip,$(CONFIG_VERSION_MANUFACTURER_URL))
-VERSION_MANUFACTURER_URL:=$(if $(VERSION_MANUFACTURER_URL),$(VERSION_MANUFACTURER_URL),http://lede-project.org/)
+VERSION_MANUFACTURER_URL:=$(if $(VERSION_MANUFACTURER_URL),$(VERSION_MANUFACTURER_URL),http://openwrt.org/)
 
 VERSION_BUG_URL:=$(call qstrip,$(CONFIG_VERSION_BUG_URL))
-VERSION_BUG_URL:=$(if $(VERSION_BUG_URL),$(VERSION_BUG_URL),http://bugs.lede-project.org/)
+VERSION_BUG_URL:=$(if $(VERSION_BUG_URL),$(VERSION_BUG_URL),http://bugs.openwrt.org/)
+
+VERSION_HOME_URL:=$(call qstrip,$(CONFIG_VERSION_HOME_URL))
+VERSION_HOME_URL:=$(if $(VERSION_HOME_URL),$(VERSION_HOME_URL),http://openwrt.org/)
 
 VERSION_SUPPORT_URL:=$(call qstrip,$(CONFIG_VERSION_SUPPORT_URL))
 VERSION_SUPPORT_URL:=$(if $(VERSION_SUPPORT_URL),$(VERSION_SUPPORT_URL),http://forum.lede-project.org/)
@@ -85,7 +89,7 @@ $(subst &,\&,$(subst $(comma),\$(comma),$(subst ','\'',$(subst \,\\,$(1)))))
 endef
 #'
 
-VERSION_SED:=$(SED) 's,%U,$(call sed_escape,$(VERSION_REPO)),g' \
+VERSION_SED_SCRIPT:=$(SED) 's,%U,$(call sed_escape,$(VERSION_REPO)),g' \
        -e 's,%V,$(call sed_escape,$(VERSION_NUMBER)),g' \
        -e 's,%v,\L$(call sed_escape,$(subst $(space),_,$(VERSION_NUMBER))),g' \
        -e 's,%C,$(call sed_escape,$(VERSION_CODE)),g' \
@@ -100,8 +104,8 @@ VERSION_SED:=$(SED) 's,%U,$(call sed_escape,$(VERSION_REPO)),g' \
        -e 's,%M,$(call sed_escape,$(VERSION_MANUFACTURER)),g' \
        -e 's,%m,$(call sed_escape,$(VERSION_MANUFACTURER_URL)),g' \
        -e 's,%b,$(call sed_escape,$(VERSION_BUG_URL)),g' \
+       -e 's,%u,$(call sed_escape,$(VERSION_HOME_URL)),g' \
        -e 's,%s,$(call sed_escape,$(VERSION_SUPPORT_URL)),g' \
        -e 's,%P,$(call sed_escape,$(VERSION_PRODUCT)),g' \
        -e 's,%h,$(call sed_escape,$(VERSION_HWREV)),g'
 
-VERSION_SED_SCRIPT:=$(VERSION_SED)