add portability fixes for toolchain/tools (full tools/toolchain build works on osx...
[openwrt/openwrt.git] / openwrt / include / host-build.mk
index 9a5a41317efcb5e649a1fa111ab953a1157cca5a..c19cb8fd1c2cfd257757ee54b033cc758104cf4a 100644 (file)
@@ -4,6 +4,7 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
+OS:=$(shell uname)
 ifneq ($(strip $(PKG_CAT)),)
   ifeq ($(PKG_CAT),unzip)
     UNPACK=unzip -d $(PKG_BUILD_DIR) $(DL_DIR)/$(PKG_SOURCE)