Port kmod-ipip to the new module layout
[openwrt/openwrt.git] / openwrt / include / modules-2.6.mk
index 4ea28fb1679e10aab739035c7dc7c7f1826f4567..fecaaba6049b18f13f41426df767934bc032200c 100644 (file)
@@ -15,22 +15,6 @@ $(eval $(call KMOD_template,ATM,atm,\
        $(MODULES_DIR)/kernel/drivers/atm/atmtcp.ko \
 ,CONFIG_ATM,,50,atm))
 
-$(eval $(call KMOD_template,GRE,gre,\
-       $(MODULES_DIR)/kernel/net/ipv4/ip_gre.ko \
-,CONFIG_NET_IPGRE))
-
-$(eval $(call KMOD_template,IPIP,ipip,\
-       $(MODULES_DIR)/kernel/net/ipv4/ipip.ko \
-,CONFIG_NET_IPIP,,60,ipip))
-
-$(eval $(call KMOD_template,SCHED,sched,\
-       $(MODULES_DIR)/kernel/net/sched/*.ko \
-,CONFIG_NET_SCHED))
-
-$(eval $(call KMOD_template,TUN,tun,\
-       $(MODULES_DIR)/kernel/drivers/net/tun.ko \
-,CONFIG_TUN,,20,tun))
-
 # Block devices
 
 $(eval $(call KMOD_template,LOOP,loop,\