add support for Package/<pkgname>/description - old format still supported, but depre...
[openwrt/openwrt.git] / openwrt / include / package.mk
index bf2376dcd02ce6724f86d9d05370a227134939dc..7ae95f8fe8699206c12083661b3910969d4f9f22 100644 (file)
@@ -10,22 +10,28 @@ else
   all: compile
 endif
 
+include $(INCLUDE_DIR)/prereq.mk
+
+define shvar
+V_$(subst .,_,$(subst -,_,$(subst /,_,$(1))))
+endef
+
+define shexport
+$(call shvar,$(1))=$$(call $(1))
+export $(call shvar,$(1))
+endef
+
 define Build/DefaultTargets
   ifeq ($(DUMP),)
-    ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) .),$(PKG_BUILD_DIR))
-      ifeq ($(CONFIG_AUTOREBUILD),y)
+    ifeq ($(CONFIG_AUTOREBUILD),y)
+      _INFO:=
+      ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) .),$(PKG_BUILD_DIR))
+        _INFO+=$(subst $(TOPDIR)/,,$(PKG_BUILD_DIR))
         $(PKG_BUILD_DIR)/.prepared: package-clean
       endif
     endif
-
-    ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg $(IPKG_$(1)) $(PKG_BUILD_DIR)),$(IPKG_$(1)))
-      ifeq ($(CONFIG_AUTOREBUILD),y)
-        $(PKG_BUILD_DIR)/.built: package-rebuild
-      endif
-    endif
   endif
 
-
   $(PKG_BUILD_DIR)/.prepared:
        @-rm -rf $(PKG_BUILD_DIR)
        @mkdir -p $(PKG_BUILD_DIR)
@@ -40,18 +46,23 @@ define Build/DefaultTargets
        $(call Build/Compile)
        touch $$@
 
-  $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed: $(PKG_BUILD_DIR)/.built
+  ifdef Build/InstallDev
+    ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg -x ipkg-install $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed $(PKG_BUILD_DIR)),$(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed)
+      $(PKG_BUILD_DIR)/.built: package-rebuild
+    endif
+
+    $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed: $(PKG_BUILD_DIR)/.built
+       mkdir -p $(STAGING_DIR)/stampfiles
        $(call Build/InstallDev)
        touch $$@
        
-  ifdef Build/InstallDev
     compile-targets: $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed
   endif
 
   package-clean: FORCE
        $(call Build/Clean)
        $(call Build/UninstallDev)
-       rm -f $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed
+       -rm -f $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed
 
   package-rebuild: FORCE
        @-rm -f $(PKG_BUILD_DIR)/.built
@@ -65,6 +76,7 @@ define Package/Default
   SECTION:=opt
   CATEGORY:=Extra packages
   DEPENDS:=
+  EXTRA_DEPENDS:=
   MAINTAINER:=OpenWrt Developers Team <openwrt-devel@openwrt.org>
   SOURCE:=$(patsubst $(TOPDIR)/%,%,${shell pwd})
   ifneq ($(PKG_VERSION),)
@@ -81,87 +93,112 @@ define Package/Default
   DEFAULT:=
   MENU:=
   SUBMENU:=
+  SUBMENUDEP:=
   TITLE:=
   DESCRIPTION:=
 endef
 
+define BuildDescription
+  ifneq ($(DESCRIPTION),)
+    DESCRIPTION:=$(TITLE)\\ $(DESCRIPTION)
+  else
+    DESCRIPTION:=$(TITLE)
+  endif
+endef
+
 define BuildIPKGVariable
-pkg_$(subst .,_,$(subst -,_,$(1)))_$(2) = $$(Package/$(1)/$(2))
-export pkg_$(subst .,_,$(subst -,_,$(1))_$(2))
-$(1)_COMMANDS += if [ -n "$$$$$$$$pkg_$(subst .,_,$(subst -,_,$(1)))_$(2)" ]; then echo "$$$$$$$$pkg_$(subst .,_,$(subst -,_,$(1)))_$(2)" > $(2); fi;
+  $(call shexport,Package/$(1)/$(2))
+  $(1)_COMMANDS += var2file "$(call shvar,Package/$(1)/$(2))" $(2);
 endef
 
 define BuildPackage
   $(eval $(call Package/Default))
   $(eval $(call Package/$(1)))
+  $(eval $(call BuildDescription))
 
-  $(foreach FIELD, TITLE CATEGORY PRIORITY VERSION,
+  $(foreach FIELD, TITLE CATEGORY PRIORITY SECTION VERSION,
     ifeq ($($(FIELD)),)
       $$(error Package/$(1) is missing the $(FIELD) field)
     endif
   )
 
-  ifeq ($(PKGARCH),)
-    PKGARCH:=$(ARCH)
-  endif
-
-  ifeq ($(DESCRIPTION),)
-    $(eval DESCRIPTION:=$(TITLE))
-  endif
-
   IPKG_$(1):=$(PACKAGE_DIR)/$(1)_$(VERSION)_$(PKGARCH).ipk
   IDIR_$(1):=$(PKG_BUILD_DIR)/ipkg/$(1)
   INFO_$(1):=$(IPKG_STATE_DIR)/info/$(1).list
 
-  ifeq ($(CONFIG_PACKAGE_$(1)),y)
-    install-targets: $$(INFO_$(1))
+  ifdef Package/$(1)/install
+    ifeq ($(CONFIG_PACKAGE_$(1)),y)
+      install-targets: $$(INFO_$(1))
+    endif
+
+    ifneq ($(CONFIG_PACKAGE_$(1)),)
+      compile-targets: $$(IPKG_$(1))
+    else
+      compile-targets: $(1)-disabled
+      $(1)-disabled:
+       @echo "WARNING: skipping $(1) -- package not selected"
+    endif
   endif
 
-  ifneq ($(CONFIG_PACKAGE_$(1))$(DEVELOPER),)
-    compile-targets: $$(IPKG_$(1))
+  ifeq ($(FORCEREBUILD),y)
+    $$(IPKG_$(1)): FORCE
   endif
 
   IDEPEND_$(1):=$$(strip $$(DEPENDS))
 
-  DUMPINFO += \
+  ifneq ($(DUMP),)
+    DUMPINFO += \
        echo "Package: $(1)"; 
 
-  ifneq ($(MENU),)
-    DUMPINFO += \
+    ifneq ($(MENU),)
+      DUMPINFO += \
        echo "Menu: $(MENU)";
-  endif
+    endif
 
-  ifneq ($(SUBMENU),)
-    DUMPINFO += \
+    ifneq ($(SUBMENU),)
+      DUMPINFO += \
        echo "Submenu: $(SUBMENU)";
-  endif
+      ifneq ($(SUBMENUDEP),)
+        DUMPINFO += \
+         echo "Submenu-Depends: $(SUBMENUDEP)";
+      endif
+    endif
 
-  ifneq ($(DEFAULT),)
-    DUMPINFO += \
+    ifneq ($(DEFAULT),)
+      DUMPINFO += \
        echo "Default: $(DEFAULT)";
-  endif
+    endif
+
+       $(call shexport,Package/$(1)/description)
 
-  DUMPINFO += \
+    DUMPINFO += \
+       if [ "$$$$PREREQ_CHECK" = 1 ]; then echo "Prereq-Check: 1"; fi; \
        echo "Version: $(VERSION)"; \
        echo "Depends: $$(IDEPEND_$(1))"; \
        echo "Build-Depends: $(PKG_BUILDDEP)"; \
        echo "Category: $(CATEGORY)"; \
        echo "Title: $(TITLE)"; \
-       echo "Description: $(DESCRIPTION)" | sed -e 's,\\,\n,g';
-
-  ifneq ($(URL),)
-    DUMPINFO += \
-       echo; \
-       echo "$(URL)";
-  endif
-
-  DUMPINFO += \
-       echo "@@";
-
-  ifneq ($(CONFIG),)
-    DUMPINFO += \
-       echo "Config: $(CONFIG)" | sed -e 's,\\,\n,g'; \
-       echo "@@";
+       if isset $(call shvar,Package/$(1)/description); then \
+               echo -n "Description: "; \
+               getvar $(call shvar,Package/$(1)/description); \
+       else \
+               echo "Description: $(DESCRIPTION)" | sed -e 's,\\,\n,g'; \
+       fi;
+       
+    ifneq ($(URL),)
+      DUMPINFO += \
+               echo; \
+               echo "$(URL)";
+    endif
+       
+       DUMPINFO += \
+               echo "@@";
+
+       $(call shexport,Package/$(1)/config)
+       DUMPINFO += \
+               if isset $(call shvar,Package/$(1)/config); then echo "Config: "; getvar $(call shvar,Package/$(1)/config); fi; \
+               echo "@@";
+  
   endif
 
   $(eval $(call BuildIPKGVariable,$(1),conffiles))
@@ -169,7 +206,7 @@ define BuildPackage
   $(eval $(call BuildIPKGVariable,$(1),postinst))
   $(eval $(call BuildIPKGVariable,$(1),prerm))
   $(eval $(call BuildIPKGVariable,$(1),postrm))
-  $$(IDIR_$(1))/CONTROL/control: $(PKG_BUILD_DIR)/.prepared
+  $$(IDIR_$(1))/CONTROL/control: $(PKG_BUILD_DIR)/.version-$(1)_$(VERSION)_$(PKGARCH)
        mkdir -p $$(IDIR_$(1))/CONTROL
        echo "Package: $(1)" > $$(IDIR_$(1))/CONTROL/control
        echo "Version: $(VERSION)" >> $$(IDIR_$(1))/CONTROL/control
@@ -178,20 +215,20 @@ define BuildPackage
                for depend in $$(filter-out @%,$$(IDEPEND_$(1))); do \
                        DEPENDS=$$$${DEPENDS:+$$$$DEPENDS, }$$$${depend##+}; \
                done; \
-               echo "Depends: $$$$DEPENDS" >> $$(IDIR_$(1))/CONTROL/control; \
+               echo "Depends: $(EXTRA_DEPENDS) $$$$DEPENDS" >> $$(IDIR_$(1))/CONTROL/control; \
        )
        echo "Source: $(SOURCE)" >> $$(IDIR_$(1))/CONTROL/control
        echo "Section: $(SECTION)" >> $$(IDIR_$(1))/CONTROL/control
        echo "Priority: $(PRIORITY)" >> $$(IDIR_$(1))/CONTROL/control
        echo "Maintainer: $(MAINTAINER)" >> $$(IDIR_$(1))/CONTROL/control
        echo "Architecture: $(PKGARCH)" >> $$(IDIR_$(1))/CONTROL/control
-       echo "Description: $(DESCRIPTION)" | sed -e 's,\\,\n ,g' >> $$(IDIR_$(1))/CONTROL/control
+       echo "Description: $(DESCRIPTION)" | sed -e 's,\\,\n,g' | sed -e 's,^[[:space:]]*$$$$, .,g' >> $$(IDIR_$(1))/CONTROL/control
        chmod 644 $$(IDIR_$(1))/CONTROL/control
        (cd $$(IDIR_$(1))/CONTROL; \
                $($(1)_COMMANDS) \
        )
 
-  $$(IPKG_$(1)): $$(IDIR_$(1))/CONTROL/control $(PKG_BUILD_DIR)/.built
+  $$(IPKG_$(1)): $(PKG_BUILD_DIR)/.built $$(IDIR_$(1))/CONTROL/control
        $(call Package/$(1)/install,$$(IDIR_$(1)))
        mkdir -p $(PACKAGE_DIR)
        -find $$(IDIR_$(1)) -name CVS | xargs rm -rf
@@ -199,6 +236,7 @@ define BuildPackage
        -find $$(IDIR_$(1)) -name '.#*' | xargs rm -f
        $(RSTRIP) $$(IDIR_$(1))
        $(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
+       @[ -f $$(IPKG_$(1)) ] || false 
 
   $$(INFO_$(1)): $$(IPKG_$(1))
        $(IPKG) install $$(IPKG_$(1))
@@ -208,8 +246,26 @@ define BuildPackage
 
   clean: $(1)-clean
 
+  $(PKG_BUILD_DIR)/.version-$(1)_$(VERSION)_$(PKGARCH): $(PKG_BUILD_DIR)/.prepared
+       -@rm $(PKG_BUILD_DIR)/.version-$(1)_* 2>/dev/null
+       @touch $$@
+
   $$(eval $$(call Build/DefaultTargets,$(1)))
 
+  ifneq ($$(CONFIG_PACKAGE_$(1)),)
+    ifneq ($(MAKECMDGOALS),prereq)
+      ifneq ($(DUMP),1)
+        ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg -x ipkg-install '$$(IPKG_$(1))' '$(PKG_BUILD_DIR)'),$$(IPKG_$(1)))
+          _INFO+=$(subst $(TOPDIR)/,,$$(IPKG_$(1)))
+          $(PKG_BUILD_DIR)/.built: package-rebuild
+        endif
+
+        ifneq ($$(_INFO),)
+          $$(info Rebuilding $$(_INFO))
+        endif
+      endif
+    endif
+  endif
 endef
 
 ifneq ($(strip $(PKG_CAT)),)
@@ -227,17 +283,19 @@ ifneq ($(strip $(PKG_CAT)),)
 endif
 
 define Build/Prepare
-  $(call Build/Prepare/Default)
+  $(call Build/Prepare/Default,)
 endef
 
 define Build/Configure/Default
-       @(cd $(PKG_BUILD_DIR)/$(3); \
-       [ -x configure ] && \
-               $(2) \
+       (cd $(PKG_BUILD_DIR)/$(3); \
+       if [ -x configure ]; then \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
+               CXXFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+               PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \
+               $(2) \
                ./configure \
                --target=$(GNU_TARGET_NAME) \
                --host=$(GNU_TARGET_NAME) \
@@ -256,7 +314,7 @@ define Build/Configure/Default
                --infodir=/usr/info \
                $(DISABLE_NLS) \
                $(1); \
-               true; \
+       fi; \
        )
 endef
 
@@ -267,9 +325,9 @@ endef
 define Build/Compile/Default
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
-               CC=$(TARGET_CC) \
                CROSS="$(TARGET_CROSS)" \
-               EXTRA_CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/include" \
+               EXTRA_CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include " \
+               EXTRA_LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib " \
                ARCH="$(ARCH)" \
                $(1);
 endef
@@ -286,7 +344,7 @@ else
        mkdir -p $@
                
   ifneq ($(strip $(PKG_SOURCE)),)
-    source: $(DL_DIR)/$(PKG_SOURCE)
+    download: $(DL_DIR)/$(PKG_SOURCE)
 
     $(DL_DIR)/$(PKG_SOURCE):
                mkdir -p $(DL_DIR)
@@ -295,7 +353,7 @@ else
     $(PKG_BUILD_DIR)/.prepared: $(DL_DIR)/$(PKG_SOURCE)
   endif
 
-  source:
+  download:
   prepare: $(PKG_BUILD_DIR)/.prepared
   configure: $(PKG_BUILD_DIR)/.configured