add support for a common shell include file, which is evaluated for every make shell...
[openwrt/openwrt.git] / openwrt / package / busybox / Makefile
index 9e30492e9062b51134dcd0eb7df78f5f1c29e2ff..f56d2462d74658b92bfc5f0f7288e08b6dcb470c 100644 (file)
@@ -31,10 +31,12 @@ define Package/busybox
        It slices, it dices, it makes Julian Fries.
   URL:=http://busybox.net/
   MENU:=1
-  CONFIG:=\\\
-       menu "Configuration" \\\
-               depends on PACKAGE_busybox \\\
-               source "$(SOURCE)/config/Config.in" \\\
+endef
+
+define Package/busybox/config
+       menu "Configuration"
+               depends on PACKAGE_busybox
+               source "$(SOURCE)/config/Config.in"
        endmenu
 endef
 
@@ -46,11 +48,21 @@ define Build/Configure
                oldconfig
 endef
 
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC="$(TARGET_CC)" \
+               CROSS="$(TARGET_CROSS)" \
+               EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
+               IPKG_ARCH="$(ARCH)" \
+               all
+endef
+
 define Package/busybox/install
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
                CROSS="$(TARGET_CROSS)" \
                EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
+               IPKG_ARCH="$(ARCH)" \
                PREFIX="$(1)" \
                install
        -rm -rf $(1)/lib64