change section from base to utils
[openwrt/openwrt.git] / openwrt / package / robocfg / Makefile
index 49f6005699797d7545fe991158aa301be1b28a29..c0e7e2c21effd681a0faec513934676179292a94 100644 (file)
@@ -1,3 +1,9 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 # $Id$
 
 include $(TOPDIR)/rules.mk
@@ -8,12 +14,15 @@ PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/robocfg
 
-include $(TOPDIR)/package/rules.mk
+include $(INCLUDE_DIR)/package.mk
 
 define Package/robocfg
-SECTION:=base
-TITLE:=BCM5325E/536x switch configuration utility
-DESCRIPTION:=Broadcom BCM5325E/536x switch configuration utility
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=BCM5325E/536x switch configuration utility
+  DESCRIPTION:=\
+       This package contains an utility for configuring the Broadcom BCM5325E/536x \\\
+       based switches.
 endef
 
 define Build/Prepare
@@ -21,12 +30,6 @@ define Build/Prepare
        $(CP) ./src/* $(PKG_BUILD_DIR)/
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" \
-               all
-endef
-
 define Package/robocfg/install
        install -d -m0755 $(1)/sbin
        install -m0755 $(PKG_BUILD_DIR)/robocfg $(1)/sbin/