kernel: add missing kconfig symbol related to SSB
[openwrt/openwrt.git] / package / Makefile
index 9b400ffeff6f2dca9274a86566def756a2743fcf..5e28720438c80d24d4d875f5ff86f9c163ddd737 100644 (file)
@@ -1,54 +1,59 @@
-# 
-# Copyright (C) 2006-2007 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 curdir:=package
 
 -include $(TMP_DIR)/.packagedeps
 $(curdir)/builddirs:=$(sort $(package-) $(package-y) $(package-m))
-$(curdir)/builddirs-default:=. $(sort $(package-y) $(package-m))
-$(curdir)/builddirs-prereq:=. $(sort $(prereq-y) $(prereq-m))
-$(curdir)/builddirs-install:=. $(sort $(package-y))
+ifeq ($(SDK),1)
+  $(curdir)/builddirs-install:=.
+else
+  $(curdir)/builddirs-default:=. $(sort $(package-y) $(package-m))
+  $(curdir)/builddirs-prereq:=. $(sort $(prereq-y) $(prereq-m))
+  $(curdir)/builddirs-install:=. $(sort $(package-y))
+endif
+ifneq ($(IGNORE_ERRORS),)
+  $(curdir)/builddirs-ignore-compile:= $(if $(filter m y, $(IGNORE_ERRORS)),$(foreach m,$(IGNORE_ERRORS),$(package-$(m))),$(package-m))
+endif
 
 $(curdir)/install:=$(curdir)/install-cleanup
 
 $(curdir)/cleanup: $(TMP_DIR)/.build
-       rm -rf $(BUILD_DIR)/root
+       rm -rf $(TARGET_DIR)
 
 $(curdir)/rootfs-prepare: $(TMP_DIR)/.build
+       @-$(MAKE) package/preconfig
        @if [ -d $(TOPDIR)/files ]; then \
-               $(CP) $(TOPDIR)/files/. $(BUILD_DIR)/root; \
+               $(CP) $(TOPDIR)/files/. $(TARGET_DIR); \
        fi
-       @mkdir -p $(BUILD_DIR)/root/etc/rc.d
+       @mkdir -p $(TARGET_DIR)/etc/rc.d
        @( \
-               cd $(BUILD_DIR)/root; \
+               cd $(TARGET_DIR); \
                for script in ./etc/init.d/*; do \
                        grep '#!/bin/sh /etc/rc.common' $$script >/dev/null || continue; \
-                       IPKG_INSTROOT=$(BUILD_DIR)/root $(which bash) ./etc/rc.common $$script enable; \
+                       IPKG_INSTROOT=$(TARGET_DIR) $$(which bash) ./etc/rc.common $$script enable; \
                done || true \
        )
-       @-find $(BUILD_DIR)/root -name CVS   | $(XARGS) rm -rf
-       @-find $(BUILD_DIR)/root -name .svn  | $(XARGS) rm -rf
-       @-find $(BUILD_DIR)/root -name '.#*' | $(XARGS) rm -f
+       @-find $(TARGET_DIR) -name CVS   | $(XARGS) rm -rf
+       @-find $(TARGET_DIR) -name .svn  | $(XARGS) rm -rf
+       @-find $(TARGET_DIR) -name '.#*' | $(XARGS) rm -f
+       $(if $(CONFIG_CLEAN_IPKG),rm -rf $(TARGET_DIR)/usr/lib/ipkg)
 
 $(curdir)/index: FORCE
-       @(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages)
+       @(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages && \
+               gzip -9c Packages > Packages.gz \
+       )
 
 $(curdir)/flags-install:= -j1
 
-$(eval $(call stampfile,$(curdir),package,prereq))
-$(eval $(call stampfile,$(curdir),package,cleanup))
-$(eval $(call stampfile,$(curdir),package,compile))
-$(eval $(call stampfile,$(curdir),package,install))
-$(eval $(call stampfile,$(curdir),package,rootfs-prepare))
-
-$($(curdir)/stamp-cleanup): $(TMP_DIR)/.build
-$($(curdir)/stamp-compile): $($(curdir)/stamp-cleanup) $(TMP_DIR)/.build
-$($(curdir)/stamp-install): $($(curdir)/stamp-compile) $(TMP_DIR)/.build
-$($(curdir)/stamp-rootfs-prepare): $($(curdir)/stamp-install) $(TMP_DIR)/.build
+$(eval $(call stampfile,$(curdir),package,prereq,.config))
+$(eval $(call stampfile,$(curdir),package,cleanup,$(TMP_DIR)/.build))
+$(eval $(call stampfile,$(curdir),package,compile,$(TMP_DIR)/.build))
+$(eval $(call stampfile,$(curdir),package,install,$(TMP_DIR)/.build))
+$(eval $(call stampfile,$(curdir),package,rootfs-prepare,$(TMP_DIR)/.build))
 
 $(eval $(call subdir,$(curdir)))