samba36: add package with hotplug.d script for auto sharing
[openwrt/openwrt.git] / package / Makefile
index ac8faecef29bcc7f150b2686d8d3c592e507c9eb..610d09d6fed6a61ed7f71bf8bc25daa4944cee2b 100644 (file)
@@ -7,6 +7,7 @@
 
 curdir:=package
 
+include $(INCLUDE_DIR)/feeds.mk
 include $(INCLUDE_DIR)/rootfs.mk
 
 -include $(TMP_DIR)/.packagedeps
@@ -63,7 +64,7 @@ endif
 $(curdir)/install: $(TMP_DIR)/.build $(curdir)/merge $(if $(CONFIG_TARGET_PER_DEVICE_ROOTFS),$(curdir)/merge-index)
        - find $(STAGING_DIR_ROOT) -type d | $(XARGS) chmod 0755
        rm -rf $(TARGET_DIR) $(TARGET_DIR_ORIG)
-       [ -d $(TARGET_DIR)/tmp ] || mkdir -p $(TARGET_DIR)/tmp
+       mkdir -p $(TARGET_DIR)/tmp
        $(call opkg,$(TARGET_DIR)) install \
                $(call opkg_package_files,$(shell cat $(PACKAGE_INSTALL_FILES) 2>/dev/null))
        @for file in $(PACKAGE_INSTALL_FILES); do \
@@ -72,11 +73,10 @@ $(curdir)/install: $(TMP_DIR)/.build $(curdir)/merge $(if $(CONFIG_TARGET_PER_DE
                        $(call opkg,$(TARGET_DIR)) flag $$flag `cat $$file`; \
                done; \
        done || true
-       @-$(MAKE) package/preconfig
 
        $(CP) $(TARGET_DIR) $(TARGET_DIR_ORIG)
 
-       $(call prepare_rootfs,$(TARGET_DIR))
+       $(call prepare_rootfs,$(TARGET_DIR),$(TOPDIR)/files)
 
 $(curdir)/index: FORCE
        @echo Generating package index...
@@ -96,8 +96,6 @@ ifdef CONFIG_SIGNED_PACKAGES
        ); done
 endif
 
-$(curdir)/preconfig:
-
 $(curdir)/flags-install:= -j1
 
 $(eval $(call stampfile,$(curdir),package,prereq,.config))