build: rework prepare_rootfs to pass target dir via parameter
[openwrt/openwrt.git] / package / Makefile
index d4081cf6897165aee2a6b1d2bc47e846d92dcfe5..857c2ebe38b155811e284be25312a95ab8e1a709 100644 (file)
@@ -56,7 +56,7 @@ $(curdir)/install: $(TMP_DIR)/.build $(curdir)/system/opkg/host/install
                done; \
        done || true
        @-$(MAKE) package/preconfig
-       $(prepare_rootfs)
+       $(call prepare_rootfs,$(TARGET_DIR))
 
 PASSOPT=""
 PASSARG=""