include/feeds.mk: rework generation of opkg distfeeds.conf
[openwrt/openwrt.git] / package / base-files / Makefile
index f35b4db79b757ecce4b7ff859e4236851d19f626..4842a45a41afac0f21b63ee2f1a71a443b234141 100644 (file)
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/version.mk
 include $(INCLUDE_DIR)/feeds.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=187
+PKG_RELEASE:=190
 PKG_FLAGS:=nonshared
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
@@ -25,9 +25,7 @@ PKG_CONFIG_DEPENDS += \
        CONFIG_NAND_SUPPORT \
        CONFIG_CLEAN_IPKG \
        CONFIG_PER_FEED_REPO \
-       CONFIG_PER_FEED_REPO_ADD_DISABLED \
-       CONFIG_PER_FEED_REPO_ADD_COMMENTED \
-       $(foreach feed,$(FEEDS_INSTALLED),CONFIG_FEED_$(feed))
+       $(foreach feed,$(FEEDS_AVAILABLE),CONFIG_FEED_$(feed))
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -39,7 +37,7 @@ endif
 define Package/base-files
   SECTION:=base
   CATEGORY:=Base system
-  DEPENDS:=+netifd +libc +procd +jsonfilter +SIGNED_PACKAGES:usign +SIGNED_PACKAGES:lede-keyring +NAND_SUPPORT:ubi-utils +fstools +fwtool
+  DEPENDS:=+netifd +libc +procd +jsonfilter +SIGNED_PACKAGES:usign +SIGNED_PACKAGES:openwrt-keyring +NAND_SUPPORT:ubi-utils +fstools +fwtool
   TITLE:=Base filesystem for OpenWrt
   URL:=http://openwrt.org/
   VERSION:=$(PKG_RELEASE)-$(REVISION)
@@ -65,8 +63,6 @@ define Package/base-files/conffiles
 /etc/shadow
 /etc/shells
 /etc/sysctl.conf
-/etc/sysctl.d/
-/etc/sysctl.d/local.conf
 /etc/sysupgrade.conf
 $(call $(TARGET)/conffiles)
 endef