include/feeds.mk: rework generation of opkg distfeeds.conf
[openwrt/openwrt.git] / package / base-files / image-config.in
index 3dfbedcfe590f15a0faa7766eb4af03429ec1534..cee8cd54e1239a3dd424fa86df8fac3eaa1d31b8 100644 (file)
@@ -24,13 +24,24 @@ config TARGET_PREINIT_SUPPRESS_STDERR
                the ash shell launched by inittab will display stderr).  That's
                the same behaviour as seen in previous version of OpenWrt.
 
+config TARGET_PREINIT_DISABLE_FAILSAFE
+       bool
+       prompt "Disable failsafe" if PREINITOPT
+       default n
+       help
+               Disable failsafe mode.  While it is very handy while
+               experimenting or developing it really ought to be
+               disabled in production environments as it is a major
+               security loophole.
+
 config TARGET_PREINIT_TIMEOUT
        int
-       prompt "Failsafe wait timeout" if PREINITOPT
+       prompt "Failsafe/Debug wait timeout" if PREINITOPT
        default 2
        help
-               How long to wait for failsafe mode to be entered before
-               continuing with a regular boot if failsafe not selected.
+               How long to wait for failsafe mode to be entered or for
+               a debug option to be pressed before continuing with a
+               regular boot.
 
 config TARGET_PREINIT_SHOW_NETMSG
        bool
@@ -45,7 +56,7 @@ config TARGET_PREINIT_SHOW_NETMSG
 
 config TARGET_PREINIT_SUPPRESS_FAILSAFE_NETMSG
        bool
-       prompt "Suppress network message indicating failsafe" if PREINITOPT
+       prompt "Suppress network message indicating failsafe" if ( PREINITOPT && !TARGET_PREINIT_SHOW_NETMSG && !TARGET_PREINIT_DISABLE_FAILSAFE )
        default n
        help
                If "Show all preinit network messages" above is not set, then
@@ -137,10 +148,10 @@ menuconfig VERSIONOPT
        default n
        help
                These options allow to override the version information embedded in
-               the /etc/openwrt_version, /etc/openwrt_release, /etc/banner and
-               /etc/opkg.conf files. Usually there is no need to set these, but
-               they're useful for release builds or custom OpenWrt redistributions
-               that should carry custom version tags.
+               the /etc/openwrt_version, /etc/openwrt_release, /etc/banner,
+               /etc/opkg.conf, and /etc/os-release files. Usually there is no need
+               to set these, but they're useful for release builds or custom OpenWrt
+               redistributions that should carry custom version tags.
 
 if VERSIONOPT
 
@@ -152,39 +163,40 @@ if VERSIONOPT
                        This is the name of the release distribution.
                        If unspecified, it defaults to OpenWrt.
 
-       config VERSION_NICK
-               string
-               prompt "Release version nickname"
-               help
-                       This is the release codename embedded in the image.
-                       If unspecified, it defaults to the name of source branch.
-
        config VERSION_NUMBER
                string
                prompt "Release version number"
                help
                        This is the release version number embedded in the image.
-                       If unspecified, it defaults to the svn or git-svn revision
-                       of the build tree.
+                       If unspecified, it defaults to SNAPSHOT for the master branch
+                       or to ##.##-SNAPSHOT on release branches.
+
+       config VERSION_CODE
+               string
+               prompt "Release version code"
+               help
+                       This is the release version code embedded in the image.
+                       If unspecified, it defaults to a revision number describing the
+                       repository version of the source, e.g. the number of commits
+                       since a branch point or a short Git commit ID.
 
        config VERSION_REPO
                string
                prompt "Release repository"
-               default "http://downloads.openwrt.org/snapshots/trunk/%S/packages"
+               default "http://downloads.openwrt.org/releases/18.06-SNAPSHOT"
                help
                        This is the repository address embedded in the image, it defaults
                        to the trunk snapshot repo; the url may contain the following placeholders:
-                        %R .. Revision number
-                        %V .. Release version or revision number, uppercase
-                        %v .. Release version or revision number, lowercase
-                        %C .. Release version or "Bleeding Edge", uppercase
-                        %c .. Release version or "bleeding_edge", lowercase
-                        %N .. Release name, uppercase
-                        %n .. Release name, lowercase
+                        %R .. Repository revision ID
+                        %V .. Configured release version number or "SNAPSHOT", uppercase
+                        %v .. Configured release version number or "snapshot", lowercase
+                        %C .. Configured release revision code or value of %R, uppercase
+                        %c .. Configured release revision code or value of %R, lowercase
                         %D .. Distribution name or "OpenWrt", uppercase
                         %d .. Distribution name or "openwrt", lowercase
                         %T .. Target name
                         %S .. Target/Subtarget name
+                        %A .. Package architecture
                         %t .. Build taint flags, e.g. "no-all busybox"
                         %M .. Manufacturer name or "OpenWrt"
                         %P .. Product name or "Generic"
@@ -204,6 +216,18 @@ if VERSIONOPT
                        This is an URL to the manufacturer's website embedded in /etc/device_info
                        Useful for OEMs building OpenWrt based firmware
 
+       config VERSION_BUG_URL
+               string
+               prompt "Bug reporting URL"
+               help
+                       This is an URL to provide users for providing bug reports
+
+       config VERSION_SUPPORT_URL
+               string
+               prompt "Support URL"
+               help
+                       This an URL to provide users seeking support
+
        config VERSION_PRODUCT
                string
                prompt "Product name"
@@ -225,6 +249,15 @@ if VERSIONOPT
                help
                        Enable this to include the version number in firmware image, SDK-
                        and Image Builder archive file names
+
+       config VERSION_CODE_FILENAMES
+               bool
+               prompt "Revision code in filenames"
+               default y
+               help
+                       Enable this to include the revision identifier or the configured
+                       version code into the firmware image, SDK- and Image Builder archive
+                       file names
 endif
 
 
@@ -235,57 +268,4 @@ menuconfig PER_FEED_REPO
                If set, a separate repository is generated within bin/*/packages/
                for the core packages and each enabled feed.
 
-       config PER_FEED_REPO_ADD_DISABLED
-               bool "Add available but not enabled feeds to opkg.conf"
-               default y
-               depends on PER_FEED_REPO
-               help
-                 Add not installed or disabled feeds from feeds.conf to opkg.conf.
-
-       config PER_FEED_REPO_ADD_COMMENTED
-               bool "Comment out not enabled feeds"
-               default y
-               depends on PER_FEED_REPO && PER_FEED_REPO_ADD_DISABLED
-               help
-                 Add not enabled feeds as commented out source lines to opkg.conf.
-
 source "tmp/.config-feeds.in"
-
-
-menuconfig SMIMEOPT
-       bool "Package signing options" if IMAGEOPT
-        default n
-       help
-               These options configure the signing key and certificate to
-               be used for signing and verifying packages.
-
-       config OPKGSMIME_CERT
-               string
-               prompt "Path to certificate (PEM certificate format)" if SMIMEOPT
-               help
-                 Path to the certificate to use for signature verification
-
-       config OPKGSMIME_KEY
-               string
-               prompt "Path to signing key (PEM private key format)" if SMIMEOPT
-               help
-                 Path to the key to use for signing packages
-
-       config OPKGSMIME_PASSPHRASE
-               bool
-               default y
-               prompt "Wait for a passphrase when signing packages?" if SMIMEOPT
-               help
-                 If this value is set, then the build will pause and request a passphrase
-                  from the command line when signing packages. This SHOULD NOT be used with
-                  automatic builds. If this value is not set, a file can be specified from
-                  which the passphrase will be read.
-
-       config OPKGSMIME_PASSFILE
-               string
-               prompt "Path to a file containing the passphrase" if SMIMEOPT
-                depends on !OPKGSMIME_PASSPHRASE
-               help
-                 Path to a file containing the passphrase for the signing key.
-                  If the signing key is not encrypted and does not require a passphrase,
-                  this option may be left blank.