at91bootstrap: bump version to v3.9.3
[openwrt/openwrt.git] / package / boot / at91bootstrap / Makefile
index 4571fedc044ac6bfb592233b541e0845d34c5d2e..eaec26b4a113780ca31af568532e4d4d13a6c964 100644 (file)
@@ -9,13 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=at91bootstrap
-PKG_VERSION:=v3.8.8
+PKG_VERSION:=v3.9.3
 PKG_RELEASE:=
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/linux4sam/at91bootstrap.git
-PKG_SOURCE_VERSION:=3d33a4e0707c61007a5278f6620453502f7500db
-
+PKG_SOURCE_VERSION:=d96833a4b6680b237708eb4dc9f10708b9e709d8
 PKG_BUILD_DIR = \
     $(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 
@@ -24,59 +23,103 @@ include $(INCLUDE_DIR)/package.mk
 
 define AT91Bootstrap/Default
   BUILD_TARGET:=at91
-  BUILD_SUBTARGET:=sama5
+  HIDDEN:=1
   AT91BOOTSTRAP_IMAGE:=at91bootstrap.bin
 endef
 
-define at91bootstrap/sama5d2_xplaineddf_uboot
-  TITLE:=AT91Bootstrap for the SAMA5D2 Xplained board (SPI Flash)
+define AT91Bootstrap/at91sam9x5eknf_uboot
+  NAME:=AT91Bootstrap for AT91SAM9X5-EK board (NandFlash)
+  BUILD_SUBTARGET:=sam9x
+  BUILD_DEVICES:=at91sam9x25ek at91sam9x35ek
+endef
+
+define AT91Bootstrap/at91sam9x5eksd_uboot
+  NAME:=AT91Bootstrap for AT91SAM9X5-EK board (SDcard)
+  BUILD_SUBTARGET:=sam9x
+  BUILD_DEVICES:=at91sam9x25ek at91sam9x35ek
+endef
+
+define AT91Bootstrap/sama5d2_xplaineddf_uboot
+  TITLE:=AT91Bootstrap for SAMA5D2 Xplained board (SPI Flash)
   BUILD_SUBTARGET:=sama5
   BUILD_DEVICES:=at91-sama5d2_xplained
 endef
 
-define at91bootstrap/sama5d2_xplaineddf_qspi_uboot
-  TITLE:=AT91Bootstrap for the SAMA5D2 Xplained board (QSPI Flash)
+define AT91Bootstrap/sama5d2_xplaineddf_qspi_uboot
+  TITLE:=AT91Bootstrap for SAMA5D2 Xplained board (QSPI Flash)
   BUILD_SUBTARGET:=sama5
   BUILD_DEVICES:=at91-sama5d2_xplained
 endef
 
-define at91bootstrap/sama5d2_xplainedsd_uboot
-  TITLE:=AT91Bootstrap for the SAMA5D2 Xplained board (SDcard/EMMC)
+define AT91Bootstrap/sama5d2_xplainedsd_uboot
+  TITLE:=AT91Bootstrap for SAMA5D2 Xplained board (SDcard/EMMC)
   BUILD_SUBTARGET:=sama5
   BUILD_DEVICES:=at91-sama5d2_xplained
 endef
 
-define at91bootstrap/sama5d3_xplainednf_uboot
-  TITLE:=AT91Bootstrap for the SAMA5D3 Xplained board (Nand Flash)
+define AT91Bootstrap/sama5d3_xplainednf_uboot
+  TITLE:=AT91Bootstrap for SAMA5D3 Xplained board (Nand Flash)
   BUILD_SUBTARGET:=sama5
   BUILD_DEVICES:=at91-sama5d3_xplained
 endef
 
-define at91bootstrap/sama5d3_xplainedsd_uboot
-  TITLE:=AT91Bootstrap for the SAMA5D3 Xplained board (SDcard)
+define AT91Bootstrap/sama5d3_xplainedsd_uboot
+  TITLE:=AT91Bootstrap for SAMA5D3 Xplained board (SDcard)
   BUILD_SUBTARGET:=sama5
   BUILD_DEVICES:=at91-sama5d3_xplained
 endef
 
-define at91bootstrap/sama5d4_xplainednf_uboot
-  TITLE:=AT91Bootstrap for the SAMA5D4 Xplained board (Nand Flash)
+define AT91Bootstrap/sama5d4_xplainednf_uboot_secure
+  TITLE:=AT91Bootstrap for SAMA5D4 Xplained board (Nand Flash)
   BUILD_SUBTARGET:=sama5
   BUILD_DEVICES:=at91-sama5d4_xplained
 endef
 
-define at91bootstrap/sama5d4_xplaineddf_uboot_secure
-  TITLE:=AT91Bootstrap for the SAMA5D4 Xplained board (SPI Flash)
+define AT91Bootstrap/sama5d4_xplaineddf_uboot_secure
+  TITLE:=AT91Bootstrap for SAMA5D4 Xplained board (SPI Flash)
   BUILD_SUBTARGET:=sama5
   BUILD_DEVICES:=at91-sama5d4_xplained
 endef
 
-define at91bootstrap/sama5d4_xplainedsd_uboot_secure
-  TITLE:=AT91Bootstrap for the SAMA5D4 Xplained board (SDcard)
+define AT91Bootstrap/sama5d4_xplainedsd_uboot_secure
+  TITLE:=AT91Bootstrap for SAMA5D4 Xplained board (SDcard)
   BUILD_SUBTARGET:=sama5
   BUILD_DEVICES:=at91-sama5d4_xplained
 endef
 
+define AT91Bootstrap/sama5d27_som1_eksd_uboot
+  TITLE:=AT91Bootstrap for SAMA5D27 SOM1 Ek (SDcard0)
+  BUILD_SUBTARGET:=sama5
+  BUILD_DEVICES:=at91-sama5d27_som1_ek
+endef
+
+define AT91Bootstrap/sama5d27_som1_eksd1_uboot
+  TITLE:=AT91Bootstrap for SAMA5D27 SOM1 Ek (SDcard1)
+  BUILD_SUBTARGET:=sama5
+  BUILD_DEVICES:=at91-sama5d27_som1_ek
+endef
+
+define AT91Bootstrap/sama5d27_som1_ekqspi_uboot
+  TITLE:=AT91Bootstrap for SAMA5D27 SOM1 Ek (QSPI Flash)
+  BUILD_SUBTARGET:=sama5
+  BUILD_DEVICES:=at91-sama5d27_som1_ek
+endef
+
+define AT91Bootstrap/sama5d2_ptc_eknf_uboot
+  TITLE:=AT91Bootstrap for SAMA5D2 PTC EK (Nand Flash)
+  BUILD_SUBTARGET:=sama5
+  BUILD_DEVICES:=at91-sama5d2_ptc_ek
+endef
+
+define AT91Bootstrap/sama5d2_ptc_eksd_uboot
+  TITLE:=AT91Bootstrap for SAMA5D2 PTC EK (SDCard)
+  BUILD_SUBTARGET:=sama5
+  BUILD_DEVICES:=at91-sama5d2_ptc_ek
+endef
+
 AT91BOOTSTRAP_TARGETS := \
+    at91sam9x5eknf_uboot \
+    at91sam9x5eksd_uboot \
     sama5d2_xplaineddf_uboot \
     sama5d2_xplaineddf_qspi_uboot \
     sama5d2_xplainedsd_uboot \
@@ -84,7 +127,11 @@ AT91BOOTSTRAP_TARGETS := \
     sama5d3_xplainedsd_uboot \
     sama5d4_xplainednf_uboot_secure \
     sama5d4_xplaineddf_uboot_secure \
-    sama5d4_xplainedsd_uboot_secure
+    sama5d4_xplainedsd_uboot_secure \
+    sama5d27_som1_eksd1_uboot \
+    sama5d27_som1_ekqspi_uboot \
+    sama5d2_ptc_eknf_uboot \
+    sama5d2_ptc_eksd_uboot
 
 define Build/Compile
        +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \