imx6: use BUILD_DEVICES in uboot-imx6 for mx6cuboxi
[openwrt/openwrt.git] / package / boot / uboot-imx6 / Makefile
index 0c989f3cfb54d8328f991bc4af6e7cbde1da77fc..3eba249bf385457ecf057a7e2ee131c6511e90b9 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2013 OpenWrt.org
+# Copyright (C) 2013-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 
 include $(TOPDIR)/rules.mk
 
-PKG_NAME:=u-boot
-PKG_VERSION:=2013.10
+PKG_VERSION:=2018.03
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:= \
-       http://mirror2.openwrt.org/sources \
-       ftp://ftp.denx.de/pub/u-boot
-PKG_MD5SUM:=a076a044b64371edc52f7e562b13f6b2
+PKG_HASH:=7e7477534409d5368eb1371ffde6820f0f79780a1a1f676161c48442cb303dfd
 
+include $(INCLUDE_DIR)/u-boot.mk
 include $(INCLUDE_DIR)/package.mk
 
-define uboot/Default
-  TITLE:=
-  CONFIG:=
-  IMAGE:=
+define U-Boot/Default
+  BUILD_TARGET:=imx6
+  UBOOT_IMAGE:=u-boot.imx
 endef
 
-define uboot/nitrogen6dl
-  TITLE:=U-Boot for Nitrogen6x i.MX6Dual-Lite 1GB board
+define U-Boot/mx6cuboxi
+   NAME:=SolidRun Cubox-i boards
+   UBOOT_IMAGE:=SPL u-boot.img
+   UBOOT_MAKE_FLAGS:=SPL u-boot.img
+   BUILD_DEVICES:=cubox-i
+   HIDDEN:=1
 endef
 
-define uboot/nitrogen6dl2g
-  TITLE:=U-Boot for Nitrogen6x i.MX6Dual-Lite 2GB board
+define U-Boot/mx6sabresd
+  NAME:=SABRE i.MX6Quad board
 endef
 
-define uboot/nitrogen6q
-  TITLE:=U-Boot for Nitrogen6x/SABRE Lite (MX6Q/1GB)
+define U-Boot/nitrogen6dl
+  NAME:=Nitrogen6x i.MX6Dual-Lite 1GB board
 endef
 
-define uboot/nitrogen6q2g
-  TITLE:=U-Boot for Nitrogen6x i.MX6Quad 2GB board
+define U-Boot/nitrogen6dl2g
+  NAME:=Nitrogen6x i.MX6Dual-Lite 2GB board
 endef
 
-define uboot/nitrogen6s
-  TITLE:=U-Boot for Nitrogen6x i.MX6Solo 512MB board
+define U-Boot/nitrogen6q
+  NAME:=Nitrogen6x/SABRE Lite (MX6Q/1GB)
 endef
 
-define uboot/nitrogen6s1g
-  TITLE:=U-Boot for Nitrogen6x i.MX6Solo 1GB board
+define U-Boot/nitrogen6q2g
+  NAME:=Nitrogen6x i.MX6Quad 2GB board
 endef
 
-define uboot/wandboard_dl
-  TITLE:=U-Boot for the Wandboard Dual Lite
+define U-Boot/nitrogen6s
+  NAME:=Nitrogen6x i.MX6Solo 512MB board
 endef
 
-define uboot/wandboard_quad
-  TITLE:=U-Boot for the Wandboard Quad
+define U-Boot/nitrogen6s1g
+  NAME:=Nitrogen6x i.MX6Solo 1GB board
 endef
 
-define uboot/wandboard_solo
-  TITLE:=U-Boot for the Wandboard Solo
+define U-Boot/wandboard
+  NAME:=Wandboard Dual Lite/Quad/Solo
+  BUILD_DEVICES:=wandboard
 endef
 
-UBOOTS := \
+UBOOT_TARGETS := \
+       mx6cuboxi \
+       mx6sabresd \
        nitrogen6dl \
        nitrogen6dl2g \
        nitrogen6q \
        nitrogen6q2g \
        nitrogen6s \
        nitrogen6s1g \
-       wandboard_dl \
-       wandboard_quad \
-       wandboard_solo
-
-define Package/uboot/template
-define Package/uboot-imx6-$(1)
-  SECTION:=boot
-  CATEGORY:=Boot Loaders
-  DEPENDS:=@TARGET_imx6
-  TITLE:=$(2)
-  URL:=http://www.denx.de/wiki/U-Boot
-  VARIANT:=$(1)
-  MAINTAINER:=Luka Perkov <luka@openwrt.org>
-endef
-endef
-
-define BuildUBootPackage
-       $(eval $(uboot/Default))
-       $(eval $(uboot/$(1)))
-       $(call Package/uboot/template,$(1),$(TITLE))
-endef
-
-ifdef BUILD_VARIANT
-$(eval $(call uboot/$(BUILD_VARIANT)))
-UBOOT_CONFIG:=$(if $(CONFIG),$(CONFIG),$(BUILD_VARIANT))
-UBOOT_IMAGE:=$(if $(IMAGE),$(IMAGE),openwrt-$(BOARD)-$(BUILD_VARIANT)-u-boot.bin)
-endif
-
-define Build/Configure
-       $(MAKE) -C $(PKG_BUILD_DIR) $(UBOOT_CONFIG)_config
-endef
-
-define Build/Compile
-       $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) CROSS_COMPILE=$(TARGET_CROSS)
-endef
+       wandboard
 
-define Package/uboot/install/default
-       $(INSTALL_DIR) $(BIN_DIR)/uboot-$(BOARD)-$(1)
-       $(CP) \
-               $(PKG_BUILD_DIR)/u-boot.imx \
-               $(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-u-boot.imx
-endef
+UBOOT_MAKE_FLAGS += u-boot.imx
 
-define Package/uboot/install/template
-define Package/uboot-imx6-$(1)/install
-       $(call Package/uboot/install/default,$(2))
-endef
+define Build/InstallDev
+       $(INSTALL_DIR) $(STAGING_DIR_IMAGE)
+       $(foreach img,$(UBOOT_IMAGE), \
+               $(CP) $(PKG_BUILD_DIR)/$(img) $(STAGING_DIR_IMAGE)/$(BUILD_VARIANT)-$(img); \
+       )
 endef
 
-$(foreach u,$(UBOOTS), \
-       $(eval $(call Package/uboot/install/template,$(u),$(u))) \
-)
-
-$(foreach u,$(UBOOTS), \
-       $(eval $(call BuildUBootPackage,$(u))) \
-       $(eval $(call BuildPackage,uboot-imx6-$(u))) \
-)
+$(eval $(call BuildPackage/U-Boot))