uboot-imx6: install images into STAGING_DIR_IMAGE
[openwrt/openwrt.git] / package / boot / uboot-imx6 / Makefile
index 613a5338ef5fef648a1f08d30a6c2892ad5ea9af..6973cda5aefd42c95e3e391c2bef0233b7e69c5f 100644 (file)
@@ -20,6 +20,12 @@ define U-Boot/Default
   UBOOT_IMAGE:=u-boot.imx
 endef
 
+define U-Boot/mx6cuboxi
+   NAME:=SolidRun Cubox-i boards
+   UBOOT_IMAGE:=SPL u-boot.img
+   UBOOT_MAKE_FLAGS:=SPL u-boot.img
+endef
+
 define U-Boot/mx6sabresd
   NAME:=SABRE i.MX6Quad board
 endef
@@ -54,6 +60,7 @@ define U-Boot/wandboard
 endef
 
 UBOOT_TARGETS := \
+       mx6cuboxi \
        mx6sabresd \
        nitrogen6dl \
        nitrogen6dl2g \
@@ -65,4 +72,11 @@ UBOOT_TARGETS := \
 
 UBOOT_MAKE_FLAGS += u-boot.imx
 
+define Build/InstallDev
+       $(INSTALL_DIR) $(STAGING_DIR_IMAGE)
+       $(foreach img,$(UBOOT_IMAGE), \
+               $(CP) $(PKG_BUILD_DIR)/$(img) $(STAGING_DIR_IMAGE)/$(BUILD_VARIANT)-$(img); \
+       )
+endef
+
 $(eval $(call BuildPackage/U-Boot))