kirkwood: sync image filename with boardname
[openwrt/openwrt.git] / package / boot / uboot-kirkwood / Makefile
index 45046690ff5cdc2ee9cf0b13eb6aa4cade1cd9b5..2b6f00f50f0567751e596f0f6c1123dbbc060fd6 100644 (file)
@@ -7,98 +7,91 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_NAME:=u-boot
-PKG_VERSION:=2014.04
+PKG_VERSION:=2017.09
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:= \
-       http://mirror2.openwrt.org/sources \
-       ftp://ftp.denx.de/pub/u-boot
-PKG_MD5SUM:=6d2116d1385a66e9a59742caa9d62a54
-PKG_TARGETS:=bin
-
-PKG_BUILD_PARALLEL:=1
+PKG_HASH:=b2d15f2cf5f72e706025cde73d67247c6da8cd35f7e10891eefe7d9095089744
 
+include $(INCLUDE_DIR)/u-boot.mk
 include $(INCLUDE_DIR)/package.mk
 
-define uboot/Default
-  TITLE:=
-  CONFIG:=
-  IMAGE:=
+define U-Boot/Default
+  BUILD_TARGET:=kirkwood
 endef
 
-define uboot/dockstar
-  TITLE:=U-Boot for Seagate DockStar
+define U-Boot/dockstar
+  NAME:=Seagate DockStar
+  BUILD_DEVICES:=seagate_dockstar
 endef
 
-define uboot/dockstar_second_stage
-  TITLE:=second stage U-Boot for Seagate DockStar
+define U-Boot/dockstar_second_stage
+  NAME:=Seagate DockStar (second stage)
+  BUILD_DEVICES:=seagate_dockstar
 endef
 
-define uboot/goflexhome
-  TITLE:=U-Boot for the Seagate GoFlexHome/GoFlexNet
+define U-Boot/goflexhome
+  NAME:=the Seagate GoFlexHome/GoFlexNet
+  BUILD_DEVICES:=seagate_goflexhome seagate_goflexnet
 endef
 
-define uboot/ib62x0
-  TITLE:=U-Boot for RaidSonic ICY BOX NAS6210 and NAS6220
+define U-Boot/ib62x0
+  NAME:=RaidSonic ICY BOX NAS6210 and NAS6220
+  BUILD_DEVICES:=raidsonic_ib-nas62x0
 endef
 
-define uboot/ib62x0_second_stage
-  TITLE:=second stage U-Boot for RaidSonic ICY BOX NAS6210 and NAS6220
+define U-Boot/ib62x0_second_stage
+  NAME:=RaidSonic ICY BOX NAS6210 and NAS6220 (second stage)
+  BUILD_DEVICES:=raidsonic_ib-nas62x0
 endef
 
-define uboot/iconnect
-  TITLE:=U-Boot for Iomega iConnect Wireless
+define U-Boot/iconnect
+  NAME:=Iomega iConnect Wireless
+  BUILD_DEVICES:=iom_iconnect-1.1
 endef
 
-define uboot/iconnect_second_stage
-  TITLE:=second stage U-Boot for Iomega iConnect Wireless
+define U-Boot/iconnect_second_stage
+  NAME:=Iomega iConnect Wireless (second stage)
+  BUILD_DEVICES:=iom_iconnect-1.1
 endef
 
-define uboot/pogo_e02
-  TITLE:=U-Boot for Cloud Engines Pogoplug E02
+define U-Boot/nsa310
+  NAME:=Zyxel NSA310
+  BUILD_DEVICES:=zyxel_nsa310b
 endef
 
-define uboot/sheevaplug
-  TITLE:=U-Boot for SheevaPlug
+define U-Boot/nsa325
+  NAME:=Zyxel NSA325v1 and v2
+  BUILD_DEVICES:=zyxel_nsa325
 endef
 
-UBOOTS:= \
-       dockstar dockstar_second_stage \
-       goflexhome \
-       ib62x0 ib62x0_second_stage \
-       iconnect iconnect_second_stage \
-       pogo_e02 \
-       sheevaplug
-
-define Package/uboot/template
-define Package/uboot-kirkwood-$(1)
-  SECTION:=boot
-  CATEGORY:=Boot Loaders
-  DEPENDS:=@TARGET_kirkwood
-  TITLE:=$(2)
-  URL:=http://www.denx.de/wiki/U-Boot
-  VARIANT:=$(1)
-endef
+define U-Boot/pogo_e02
+  NAME:=Cloud Engines Pogoplug E02
+  BUILD_DEVICES:=cloudengines_pogoe02
 endef
 
-define BuildUBootPackage
-       $(eval $(uboot/Default))
-       $(eval $(uboot/$(1)))
-       $(call Package/uboot/template,$(1),$(TITLE))
+define U-Boot/pogo_e02_second_stage
+  NAME:=Cloud Engines Pogoplug E02 (second stage)
+  BUILD_DEVICES:=cloudengines_pogoe02
 endef
 
-ifdef BUILD_VARIANT
-$(eval $(call uboot/$(BUILD_VARIANT)))
-UBOOT_CONFIG:=$(if $(CONFIG),$(CONFIG),$(BUILD_VARIANT))
-UBOOT_IMAGE:=$(if $(IMAGE),$(IMAGE),openwrt-$(BOARD)-$(BUILD_VARIANT)-u-boot.bin)
-endif
+UBOOT_TARGETS := \
+       dockstar dockstar_second_stage \
+       goflexhome \
+       ib62x0 ib62x0_second_stage \
+       iconnect iconnect_second_stage \
+       nsa310 \
+       nsa325 \
+       pogo_e02 pogo_e02_second_stage
 
 define Build/Configure
+       $(if $(findstring _second_stage,$(BUILD_VARIANT)),
+               $(CP) \
+                       $(PKG_BUILD_DIR)/configs/$(subst _second_stage,,$(BUILD_VARIANT))_defconfig \
+                       $(PKG_BUILD_DIR)/configs/$(BUILD_VARIANT)_defconfig
+               echo CONFIG_SECOND_STAGE=y >> $(PKG_BUILD_DIR)/configs/$(BUILD_VARIANT)_defconfig
+       )
        +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
-               $(UBOOT_CONFIG)_config
+               $(BUILD_VARIANT)_config V=1
 endef
 
 define Build/Compile
@@ -107,34 +100,21 @@ define Build/Compile
                CROSS_COMPILE=$(TARGET_CROSS)
        mkimage -A $(ARCH) -O linux -T kernel -C none \
                -a 0x600000 -e 0x600000 \
-               -n 'OpenWrt Das U-Boot uImage' \
+               -n 'U-Boot uImage' \
                -d $(PKG_BUILD_DIR)/u-boot.bin $(PKG_BUILD_DIR)/u-boot.img
 endef
 
-define Package/uboot/install/default
-       $(INSTALL_DIR) $(BIN_DIR)/uboot-$(BOARD)-$(1)
-       $(CP) $(PKG_BUILD_DIR)/u-boot.bin \
-               $(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-u-boot.bin
-       $(CP) $(PKG_BUILD_DIR)/u-boot.kwb \
-               $(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-u-boot.kwb
-       $(CP) $(PKG_BUILD_DIR)/u-boot.img \
-               $(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-u-boot.img
-       $(INSTALL_DIR) $(BIN_DIR)/u-boot-kwboot/
-       $(CP) $(PKG_BUILD_DIR)/tools/kwboot \
-               $(BIN_DIR)/u-boot-kwboot/
+define Package/u-boot/install
+       $(CP) \
+               $(PKG_BUILD_DIR)/u-boot.bin \
+               $(PKG_BUILD_DIR)/u-boot.kwb \
+               $(PKG_BUILD_DIR)/u-boot.img \
+               $(1)/
 endef
 
-define Package/uboot/install/template
-define Package/uboot-kirkwood-$(1)/install
-       $(call Package/uboot/install/default,$(2))
-endef
+define Build/InstallDev
+       $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/tools/kwboot $(STAGING_DIR_HOST)/bin/
 endef
 
-$(foreach u,$(UBOOTS), \
-       $(eval $(call Package/uboot/install/template,$(u),$(u))) \
-)
-
-$(foreach u,$(UBOOTS), \
-       $(eval $(call BuildUBootPackage,$(u))) \
-       $(eval $(call BuildPackage,uboot-kirkwood-$(u))) \
-)
+$(eval $(call BuildPackage/U-Boot))