packages: uboot-mxs: do no modify the U-Boot image, copy as-is
[openwrt/openwrt.git] / package / boot / uboot-mxs / Makefile
index 4cf17abfe148c53815d13ac61efe4a8fefc62970..eee73d27b42ee1927385036145577fee33907999 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2013 OpenWrt.org
+# Copyright (C) 2013-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=u-boot
-PKG_VERSION:=2013.07
+PKG_VERSION:=2015.07
 PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
@@ -16,7 +16,10 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
        http://mirror2.openwrt.org/sources \
        ftp://ftp.denx.de/pub/u-boot
-PKG_MD5SUM:=8445162690052e6afd4b8f87af2bb557
+PKG_MD5SUM:=3dac9a0b46fed77fc768ad3bd2d68c05
+
+PKG_LICENSE:=GPL-2.0 GPL-2.0+
+PKG_LICENSE_FILES:=Licenses/README
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,11 +30,16 @@ define uboot/Default
 endef
 
 define uboot/mx23_olinuxino
-  TITLE:=U-Boot 2013.07 for the Olinuxino i.MX233
+  TITLE:=U-Boot 2015.07 for the Olinuxino i.MX233
+endef
+
+define uboot/duckbill
+  TITLE:=U-Boot 2015.07 for the I2SE Duckbill
 endef
 
 UBOOTS := \
-       mx23_olinuxino
+       mx23_olinuxino \
+       duckbill
 
 define Package/uboot/template
 define Package/uboot-mxs-$(1)
@@ -67,10 +75,9 @@ define Build/Compile
                CROSS_COMPILE=$(TARGET_CROSS) u-boot.sb
 endef
 
-
 define Package/uboot/install/default
        $(INSTALL_DIR) $(BIN_DIR)/uboot-$(BOARD)-$(1)
-       dd if=$(PKG_BUILD_DIR)/u-boot.sb of=$(BIN_DIR)/uboot-$(BOARD)-$(1).sb bs=512 seek=4
+       $(CP) $(PKG_BUILD_DIR)/u-boot.sb $(BIN_DIR)/uboot-$(BOARD)-$(1)/uboot-$(BOARD)-$(1).sb
 endef
 
 define Package/uboot/install/template