uboot-omap: Do not hide bootloader packages
[openwrt/openwrt.git] / package / boot / uboot-omap / Makefile
index e21e2e1b2b080dc23eec471f1e1080ce56381c3e..1b73f1c9f0455c801c2a5fe646cfde169215e958 100644 (file)
@@ -7,97 +7,37 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_NAME:=u-boot
-PKG_VERSION:=2013.10
+PKG_VERSION:=2015.10
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:= \
-       http://mirror2.openwrt.org/sources \
-       ftp://ftp.denx.de/pub/u-boot
-PKG_MD5SUM:=a076a044b64371edc52f7e562b13f6b2
-
-PKG_LICENSE:=GPL-2.0 GPL-2.0+
-PKG_LICENSE_FILES:=Licenses/README
+PKG_HASH:=bdc68d5f9455ad933b059c735d983f2c8b6b552dafb062e5ff1444f623021955
 
+include $(INCLUDE_DIR)/u-boot.mk
 include $(INCLUDE_DIR)/package.mk
 
-define uboot/Default
-  TITLE:=
-  CONFIG:=
-  IMAGE:=
-endef
-
-define uboot/omap4_panda
-  TITLE:=U-Boot for the Pandaboard
-endef
-
-define uboot/am335x_evm
-  TITLE:=U-Boot for the AM335x EVM
+define U-Boot/Default
+  BUILD_TARGET:=omap
+  BUILD_DEVICES:=Default
+  UBOOT_IMAGE:=u-boot.img MLO
 endef
 
-define uboot/omap3_overo
-  TITLE:=U-Boot for the Gumstix Overo
+define U-Boot/omap4_panda
+  NAME:=Pandaboard
 endef
 
-define uboot/omap3_beagle
-  TITLE:=U-Boot for the BeagleBoard
-endef
-
-UBOOTS:=omap4_panda am335x_evm omap3_overo omap3_beagle
-
-define Package/uboot/template
-define Package/uboot-omap-$(1)
-  SECTION:=boot
-  CATEGORY:=Boot Loaders
-  DEPENDS:=@TARGET_omap
-  TITLE:=$(2)
-  URL:=http://www.denx.de/wiki/U-Boot
-  VARIANT:=$(1)
-  HIDDEN:=1
-endef
+define U-Boot/am335x_evm
+  NAME:=AM335x EVM
 endef
 
-define BuildUBootPackage
-       $(eval $(uboot/Default))
-       $(eval $(uboot/$(1)))
-       $(call Package/uboot/template,$(1),$(TITLE))
+define U-Boot/omap3_overo
+  NAME:=Gumstix Overo
 endef
 
-ifdef BUILD_VARIANT
-$(eval $(call uboot/$(BUILD_VARIANT)))
-UBOOT_CONFIG:=$(if $(CONFIG),$(CONFIG),$(BUILD_VARIANT))
-UBOOT_IMAGE:=$(if $(IMAGE),$(IMAGE),openwrt-$(BOARD)-$(BUILD_VARIANT)-u-boot.img)
-endif
-
-define Build/Configure
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               USE_PRIVATE_LIBGCC=yes $(UBOOT_CONFIG)_config
-endef
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CROSS_COMPILE=$(TARGET_CROSS)
-endef
-
-define Package/uboot/install/default
-       $(INSTALL_DIR) $(BIN_DIR)/uboot-$(BOARD)-$(1)
-       $(CP) $(PKG_BUILD_DIR)/u-boot.img $(BIN_DIR)/uboot-$(BOARD)-$(1)/u-boot.img
-       $(CP) $(PKG_BUILD_DIR)/MLO $(BIN_DIR)/uboot-$(BOARD)-$(1)/MLO
-endef
-
-define Package/uboot/install/template
-define Package/uboot-omap-$(1)/install
-       $(call Package/uboot/install/default,$(2))
-endef
+define U-Boot/omap3_beagle
+  NAME:=BeagleBoard
 endef
 
-$(foreach u,$(UBOOTS), \
-       $(eval $(call Package/uboot/install/template,$(u),$(u))) \
-)
+UBOOT_TARGETS:=omap4_panda am335x_evm omap3_overo omap3_beagle
+UBOOT_CONFIGURE_VARS += USE_PRIVATE_LIBGCC=yes
 
-$(foreach u,$(UBOOTS), \
-       $(eval $(call BuildUBootPackage,$(u))) \
-       $(eval $(call BuildPackage,uboot-omap-$(u))) \
-)
+$(eval $(call BuildPackage/U-Boot))