uboot-sunxi: fix build of HAOYU Electronics Marsboard A10
[openwrt/openwrt.git] / package / boot / uboot-sunxi / Makefile
index 50c6b06a71370f225ddd678a98dc34d8ac49de2b..056300e1899662a463c2ceca7f2e6f925eddc453 100644 (file)
@@ -96,6 +96,12 @@ define U-Boot/Hummingbird_A31
   NAME:=Hummingbird A31 board
 endef
 
+define U-Boot/Marsboard_A10
+  BUILD_SUBTARGET:=cortexa8
+  NAME:=Marsboard
+  BUILD_DEVICES:=sun4i-a10-marsboard
+endef
+
 define U-Boot/Mele_M9
   BUILD_SUBTARGET:=cortexa7
   NAME:=Mele M9 (A31)
@@ -126,6 +132,12 @@ define U-Boot/Lamobo_R1
   BUILD_DEVICES:=sun7i-a20-lamobo-r1
 endef
 
+define U-Boot/nanopi_m1_plus
+  BUILD_SUBTARGET:=cortexa7
+  NAME:=NanoPi M1 Plus (H3)
+  BUILD_DEVICES:=sun8i-h3-nanopi-m1-plus
+endef
+
 define U-Boot/nanopi_neo
   BUILD_SUBTARGET:=cortexa7
   NAME:=U-Boot for NanoPi NEO (H3)
@@ -144,6 +156,12 @@ define U-Boot/orangepi_plus
   BUILD_DEVICES:=sun8i-h3-orangepi-plus
 endef
 
+define U-Boot/orangepi_2
+  BUILD_SUBTARGET:=cortexa7
+  NAME:=Orange Pi 2 (H3)
+  BUILD_DEVICES:=sun8i-h3-orangepi-2
+endef
+
 define U-Boot/pangolin
   BUILD_SUBTARGET:=cortexa7
   NAME:=Theobroma A31-yQ7 devboard
@@ -171,14 +189,17 @@ UBOOT_TARGETS := \
        Cubieboard2 \
        Cubietruck \
        Hummingbird_A31 \
+       Marsboard_A10 \
        Mele_M9 \
        OLIMEX_A13_SOM \
        Linksprite_pcDuino \
        Linksprite_pcDuino3 \
        Lamobo_R1 \
+       nanopi_m1_plus \
        nanopi_neo \
        orangepi_r1 \
        orangepi_plus \
+       orangepi_2 \
        pangolin \
        pine64_plus