sunxi: add support for NanoPi NEO Plus2 board
[openwrt/openwrt.git] / package / boot / uboot-sunxi / Makefile
index 056300e1899662a463c2ceca7f2e6f925eddc453..321e7e9c034db1a5742afd5faf2d5632b037b016 100644 (file)
@@ -168,6 +168,14 @@ define U-Boot/pangolin
   UENV:=pangolin
 endef
 
+define U-Boot/nanopi_neo_plus2
+  BUILD_SUBTARGET:=cortexa53
+  NAME:=NanoPi NEO Plus2 (H5)
+  BUILD_DEVICES:=sun50i-h5-nanopi-neo-plus2
+  DEPENDS:=+PACKAGE_u-boot-nanopi_neo_plus2:arm-trusted-firmware-sunxi
+  UENV:=a64
+endef
+
 define U-Boot/pine64_plus
   BUILD_SUBTARGET:=cortexa53
   NAME:=Pine64 Plus A64
@@ -197,6 +205,7 @@ UBOOT_TARGETS := \
        Lamobo_R1 \
        nanopi_m1_plus \
        nanopi_neo \
+       nanopi_neo_plus2 \
        orangepi_r1 \
        orangepi_plus \
        orangepi_2 \