uboot-sunxi: update to version 2017.07
[openwrt/openwrt.git] / package / boot / uboot-sunxi / patches / 003-add-theobroma-a31-pangolin.patch
index e5a66d7ebe00e5f562348b1b6c30a22fa0736833..2fce04828c4745a9d3ee8850e2d795c7efb40f2d 100644 (file)
@@ -1,16 +1,16 @@
 --- a/arch/arm/dts/Makefile
 +++ b/arch/arm/dts/Makefile
-@@ -152,6 +152,7 @@ dtb-$(CONFIG_MACH_SUN6I) += \
+@@ -254,6 +254,7 @@ dtb-$(CONFIG_MACH_SUN6I) += \
        sun6i-a31-m9.dtb \
        sun6i-a31-mele-a1000g-quad.dtb \
        sun6i-a31-mixtile-loftq.dtb \
 +      sun6i-a31-pangolin.dtb \
+       sun6i-a31s-colorfly-e708-q1.dtb \
        sun6i-a31s-cs908.dtb \
-       sun6i-a31s-primo81.dtb \
-       sun6i-a31s-sinovoip-bpi-m2.dtb
+       sun6i-a31s-inet-q972.dtb \
 --- a/arch/arm/dts/sun6i-a31.dtsi
 +++ b/arch/arm/dts/sun6i-a31.dtsi
-@@ -643,6 +643,13 @@
+@@ -679,6 +679,13 @@
                                allwinner,pull = <SUN4I_PINCTRL_NO_PULL>;
                        };
  
 +CONFIG_DM_SPI=y
 +CONFIG_DM_SPI_FLASH=y
 +CONFIG_SUNXI_SPI=y
---- a/board/sunxi/Kconfig
-+++ b/board/sunxi/Kconfig
-@@ -15,7 +15,6 @@ config SUNXI_GEN_SUN6I
-       separate ahb reset control registers, custom pmic bus, new style
-       watchdog, etc.
--
- choice
-       prompt "Sunxi SoC Variant"
-       optional
-@@ -533,6 +532,14 @@ config VIDEO_LCD_PANEL_I2C_SCL
+--- a/arch/arm/mach-sunxi/Kconfig
++++ b/arch/arm/mach-sunxi/Kconfig
+@@ -746,6 +746,14 @@ config VIDEO_LCD_PANEL_I2C_SCL
        Set the SCL pin for the LCD i2c interface. This takes a string in the
        format understood by sunxi_name_to_gpio, e.g. PH1 for pin 1 of port H.