uboot-zynq: fix compile error for be short of dtc
[openwrt/openwrt.git] / package / boot / uboot-zynq / Makefile
index 3a17f7fcd2cee6a0f04d79e5555fecdf35dcc13d..a6e4f0a715a8a4b275a478a18ac1fa89323a41cb 100644 (file)
@@ -6,6 +6,7 @@
 #
 
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
 
 PKG_NAME:=u-boot
 PKG_VERSION:=2016.03
@@ -37,8 +38,18 @@ define uboot/zc706
        TITLE:=U-Boot $(PKG_VERSION) for Xilinx ZC706 Dev Board
 endef
 
+define uboot/zed
+       TITLE:=U-Boot $(PKG_VERSION) for Avnet Digilent ZedBoard Dev Board
+endef
+
+define uboot/zybo
+       TITLE:=U-Boot $(PKG_VERSION) for Digilent Zybo Dev Board
+endef
+
 UBOOTS := \
        zc702 \
+       zed \
+       zybo \
 
 define Package/uboot/template
 define Package/uboot-zynq-$(1)
@@ -71,7 +82,7 @@ endef
 
 define Build/Compile
        +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
-               CROSS_COMPILE=$(TARGET_CROSS)
+               CROSS_COMPILE=$(TARGET_CROSS) DTC=$(LINUX_DIR)/scripts/dtc/dtc
 endef
 
 define Package/uboot/install/default