cyassl: add a patch to better check legacy SSLv2 client hello records
[openwrt/openwrt.git] / package / busybox / Makefile
index 25828da972e62d8529385f1b87617420f5c62d4f..177a42ff33fd62f90d35ba6c7b20141c36bd856d 100644 (file)
@@ -1,5 +1,5 @@
-#
-# Copyright (C) 2006-2009 OpenWrt.org
+# 
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,18 +8,28 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
-PKG_VERSION:=1.12.4
-PKG_RELEASE:=1
+PKG_VERSION:=1.19.4
+PKG_RELEASE:=5
+PKG_FLAGS:=essential
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.busybox.net/downloads \
                http://distfiles.gentoo.org/distfiles/
-PKG_MD5SUM:=5b8c427bf596732d6b6156672e6e093f
+PKG_MD5SUM:=9c0cae5a0379228e7b55e5b29528df8e
+
+PKG_BUILD_DEPENDS:=BUSYBOX_CONFIG_FEATURE_HAVE_RPC:librpc
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 ifeq ($(DUMP),)
-  STAMP_CONFIGURED:=$(strip $(STAMP_CONFIGURED))_$(shell grep '^CONFIG_BUSYBOX_' $(TOPDIR)/.config | md5s)
+  STAMP_CONFIGURED:=$(strip $(STAMP_CONFIGURED))_$(shell $(SH_FUNC) grep '^CONFIG_BUSYBOX_' $(TOPDIR)/.config | md5s)
+endif
+
+ifneq ($(findstring c,$(OPENWRT_VERBOSE)),)
+  BB_MAKE_VERBOSE := V=1
+else
+  BB_MAKE_VERBOSE :=
 endif
 
 init-y :=
@@ -30,8 +40,10 @@ init-$(CONFIG_BUSYBOX_CONFIG_TELNETD) += telnet
 define Package/busybox
   SECTION:=base
   CATEGORY:=Base system
+  MAINTAINER:=Nicolas Thill <nico@openwrt.org>
   TITLE:=Core utilities for embedded Linux
   URL:=http://busybox.net/
+  DEPENDS:=+BUSYBOX_CONFIG_FEATURE_HAVE_RPC:librpc
   MENU:=1
 endef
 
@@ -41,11 +53,7 @@ define Package/busybox/description
 endef
 
 define Package/busybox/config
-       menu "Configuration"
-               depends on PACKAGE_busybox
-               source "$(SOURCE)/target-config.in"
-               source "$(SOURCE)/config/Config.in"
-       endmenu
+       source "$(SOURCE)/Config.in"
 endef
 
 define Build/Configure
@@ -56,16 +64,31 @@ define Build/Configure
                CROSS_COMPILE="$(TARGET_CROSS)" \
                KBUILD_HAVE_NLS=no \
                ARCH="$(ARCH)" \
+               $(BB_MAKE_VERBOSE) \
                oldconfig
 endef
 
+ifdef CONFIG_GCC_VERSION_LLVM
+  TARGET_CFLAGS += -fnested-functions
+endif
+
+LDLIBS:=m crypt
+ifdef CONFIG_BUSYBOX_CONFIG_FEATURE_HAVE_RPC
+  TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
+  export LDFLAGS=$(TARGET_LDFLAGS)
+  LDLIBS += rpc
+endif
+
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
+       +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
                CROSS_COMPILE="$(TARGET_CROSS)" \
                KBUILD_HAVE_NLS=no \
                EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
                ARCH="$(ARCH)" \
+               SKIP_STRIP=y \
+               LDLIBS="$(LDLIBS)" \
+               $(BB_MAKE_VERBOSE) \
                all
        rm -rf $(PKG_INSTALL_DIR)
        $(FIND) $(PKG_BUILD_DIR) -lname "*busybox" -exec rm \{\} \;
@@ -74,8 +97,9 @@ define Build/Compile
                CROSS_COMPILE="$(TARGET_CROSS)" \
                EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
                ARCH="$(ARCH)" \
-               IPKG_ARCH="$(ARCH)" \
                CONFIG_PREFIX="$(PKG_INSTALL_DIR)" \
+               LDLIBS="$(LDLIBS)" \
+               $(BB_MAKE_VERBOSE) \
                install
 endef