gcc: add llvm-gcc and llvm from trunk (does not successfully compile a target yet...
[openwrt/openwrt.git] / package / busybox / Makefile
index eb0f0987e75a3729f8f9de77df02da596504aacf..75bb315cc6d0adbee274c79e0740cfa3cdfd5dfa 100644 (file)
@@ -59,6 +59,10 @@ define Build/Configure
                oldconfig
 endef
 
+ifdef CONFIG_GCC_VERSION_LLVM
+  TARGET_CFLAGS += -fnested-functions
+endif
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \