Fix removing links to applets (#1770)
[openwrt/openwrt.git] / package / busybox / Makefile
index 90e3af060aeeb039db645fb62035180b5e77b513..ec9a1bad88584da99560f61085605efafc0bbc2d 100644 (file)
@@ -9,13 +9,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
-PKG_VERSION:=1.4.1
+PKG_VERSION:=1.4.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.busybox.net/downloads \
                http://distfiles.gentoo.org/distfiles/
-PKG_MD5SUM:=5728403bce309cdabcffa414e2e64052
+PKG_MD5SUM:=b4c61fb15642be9dde20e8493788c585
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -51,7 +51,7 @@ endef
 
 define Build/Configure
        rm -f $(PKG_BUILD_DIR)/.configured*
-       $(SCRIPT_DIR)/gen_busybox_config.pl $(TOPDIR)/.config > $(PKG_BUILD_DIR)/.config
+       grep 'CONFIG_BUSYBOX_' $(TOPDIR)/.config | sed -e "s,\\(# \)\\?CONFIG_BUSYBOX_\\(.*\\),\\1\\2,g" > $(PKG_BUILD_DIR)/.config
        yes '' | $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
                CROSS_COMPILE="$(TARGET_CROSS)" \
@@ -70,6 +70,7 @@ define Build/Compile
 endef
 
 define Package/busybox/install
+       find $(PKG_BUILD_DIR) -lname "*busybox" -exec rm \{\} \;
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
                CROSS_COMPILE="$(TARGET_CROSS)" \