handle the Linaro version as well
[openwrt/openwrt.git] / package / devel / binutils / Makefile
index 09710d4b9ef03a66519f6ad58ccbef7a760420d4..9c406d966618c93ac91798de8587d3564be113f7 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,10 +10,19 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=binutils
 PKG_VERSION:=$(strip $(subst ",, $(CONFIG_BINUTILS_VERSION)))
 #"))
-PKG_RELEASE:=5
-
-PKG_SOURCE_URL:=@GNU/binutils
-PKG_SOURCE:=binutils-$(PKG_VERSION).tar.bz2
+PKG_RELEASE:=6
+
+ifeq ($(findstring linaro, $(CONFIG_BINUTILS_VERSION)),linaro)
+  PKG_SOURCE_URL:=https://releases.linaro.org/13.06/components/toolchain/binutils-linaro/
+  PKG_REV:=2.23.2-2013.06
+  PKG_SOURCE:=$(PKG_NAME)-linaro-$(PKG_REV).tar.bz2
+  BINUTILS_DIR:=$(PKG_NAME)-2.23.2
+  PKG_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(BINUTILS_DIR)
+  PKG_VERSION:=$(PKG_REV)
+else
+  PKG_SOURCE_URL:=@GNU/binutils
+  PKG_SOURCE:=binutils-$(PKG_VERSION).tar.bz2
+endif
 PKG_MD5SUM:=
 
 PATCH_DIR:=$(TOPDIR)/toolchain/binutils/patches/$(PKG_VERSION)