gdb: Update to 8.1
[openwrt/openwrt.git] / package / devel / gdb / Makefile
index ffbc9199b11e98447b03e883f458ff6fe9e5fb24..e38d1c4309c7e8747bd3516bffe72fc6c816e9d7 100644 (file)
@@ -8,16 +8,17 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gdb
-PKG_VERSION:=7.12.1
-PKG_RELEASE:=2
+PKG_VERSION:=8.1
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gdb
-PKG_HASH:=4607680b973d3ec92c30ad029f1b7dbde3876869e6b3a117d8a7e90081113186
+PKG_HASH:=af61a0263858e69c5dce51eab26662ff3d2ad9aa68da9583e8143b5426be4b34
 
 PKG_BUILD_PARALLEL:=1
 PKG_INSTALL:=1
 PKG_LICENSE:=GPL-3.0+
+PKG_CPE_ID:=cpe:/a:gnu:gdb
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -55,11 +56,16 @@ CONFIGURE_ARGS+= \
        --with-system-readline \
        --without-expat \
        --without-lzma \
+       --disable-sim \
        --disable-werror
 
 CONFIGURE_VARS+= \
        ac_cv_search_tgetent="$(TARGET_LDFLAGS) -lncurses -lreadline"
 
+TARGET_LDFLAGS+= \
+       -static-libstdc++ \
+       -Wl,--gc-sections
+
 define Build/Install
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \