perf: remove linux 4.4 workarounds
[openwrt/openwrt.git] / package / devel / perf / Makefile
index c999229324a2742cd58956f10e54bb7253195fed..4defdd8c4efd8c007e0eb14287a7f213be167a3e 100644 (file)
@@ -14,6 +14,8 @@ PKG_RELEASE:=2
 
 PKG_USE_MIPS16:=0
 PKG_BUILD_PARALLEL:=1
+PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
+PKG_FLAGS:=nonshared
 
 # Perf's makefile and headers are not relocatable and must be built from the
 # Linux sources directory
@@ -24,7 +26,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/perf
   SECTION:=devel
   CATEGORY:=Development
-  DEPENDS:= @!USE_UCLIBC +libelf1 +libdw +libpthread +librt +binutils
+  DEPENDS:= +libelf1 +libdw +(mips||mipsel||powerpc||i386||x86_64||arm||aarch64):libunwind +libpthread +librt +objdump @!LINUX_3_18 @!IN_SDK @!TARGET_arc770 @KERNEL_PERF_EVENTS
   TITLE:=Linux performance monitoring tool
   VERSION:=$(LINUX_VERSION)-$(PKG_RELEASE)
   URL:=http://www.kernel.org
@@ -48,6 +50,8 @@ MAKE_FLAGS = \
        NO_LIBNUMA=1 \
        NO_GTK2=1 \
        NO_LIBAUDIT=1 \
+       NO_LIBCRYPTO=1 \
+       NO_LIBUNWIND=1 \
        CROSS_COMPILE="$(TARGET_CROSS)" \
        CC="$(TARGET_CC)" \
        LD="$(TARGET_CROSS)ld" \
@@ -57,10 +61,6 @@ MAKE_FLAGS = \
        WERROR=0 \
        prefix=/usr
 
-ifdef CONFIG_USE_MUSL
- MAKE_FLAGS += EXTRA_CFLAGS="-include $(CURDIR)/musl-compat.h -D__UCLIBC__"
-endif
-
 define Build/Compile
        +$(MAKE_FLAGS) $(MAKE) $(PKG_JOBS) \
                -C $(PKG_BUILD_DIR) \