upgrade dnsmasq (#1975)
[openwrt/openwrt.git] / package / dnsmasq / Makefile
index 6283fdc898c6b63d4bbc6bdf474b0d63fd7d74a0..de2571a79d393b2d071089766ceff0c40285a868 100644 (file)
@@ -9,22 +9,18 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
-PKG_VERSION:=2.33
+PKG_VERSION:=2.39
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
-PKG_MD5SUM:=45696461b6e6bc929273b1191ca50447
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MD5SUM:=1ffccc1f0d9b8a08f2b99e03ba9cc08b
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/dnsmasq
   SECTION:=net
   CATEGORY:=Base system
-  DEFAULT:=y
   TITLE:=A lightweight DNS and DHCP server
   DESCRIPTION:=\
        It is intended to provide coupled DNS and DHCP service to a LAN.
@@ -44,12 +40,13 @@ define Build/Compile
 endef
 
 define Package/dnsmasq/install
-       install -m0755 -d $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/src/dnsmasq $(1)/usr/sbin/
-       install -m0755 -d $(1)/etc
-       install -m0644 ./files/dnsmasq.conf $(1)/etc/dnsmasq.conf
-       install -m0755 -d $(1)/etc/init.d
-       install -m0755 ./files/dnsmasq.init $(1)/etc/init.d/S50dnsmasq
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/dnsmasq $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/dhcp.conf $(1)/etc/config/dhcp
+       $(INSTALL_DATA) ./files/dnsmasq.conf $(1)/etc/dnsmasq.conf
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/dnsmasq.init $(1)/etc/init.d/dnsmasq
 endef
 
 $(eval $(call BuildPackage,dnsmasq))