update/rename those packages
[openwrt/openwrt.git] / package / e2fsprogs / Makefile
index 79ab92c737f0932e55c35c87d95c8cd84dea7458..6b281c0f59b8b61c8a4d556967b50edb4b2b36b9 100644 (file)
@@ -8,13 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=e2fsprogs
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=e2fsprogs
-PKG_VERSION:=1.42
-PKG_MD5SUM:=a3c4ffd7352310ab5e9412965d575610
-PKG_RELEASE:=2
+PKG_VERSION:=1.42.2
+PKG_MD5SUM:=04f4561a54ad0419248316a00c016baa
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/e2fsprogs
 
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/e2fsprogs
 
+PKG_BUILD_DEPENDS:=util-linux
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
@@ -38,42 +39,6 @@ define Package/e2fsprogs/description
  filesystem utilities.
 endef
 
  filesystem utilities.
 endef
 
-define Package/libuuid
-$(call Package/e2fsprogs/Default)
-  SECTION:=libs
-  CATEGORY:=Libraries
-  TITLE:=DCE compatible Universally Unique Identifier library
-endef
-
-define Package/libuuid/description
- Library for generating DCE compatible Universally Unique Identifiers.
-endef
-
-define Package/uuidgen
-$(call Package/e2fsprogs)
-  DEPENDS:=+libuuid
-  TITLE:=Command line utility to create a new UUID value
-endef
-
-define Package/uuidgen/description
- uuidgen program creates a new universally unique identifier (UUID) 
- using the libuuid library. The new UUID can reasonably be considered 
- unique among all UUIDs created on the local system, and among UUIDs 
- created on other systems in the past and in the future.
-endef
-
-define Package/libblkid
-$(call Package/e2fsprogs/Default)
-  SECTION:=libs
-  CATEGORY:=Libraries
-  TITLE:=Block device id library
-endef
-
-define Package/libblkid/description
- The blkid library which allows system programs like fsck and mount to 
- quickly and easily find block devices by filesystem UUID and LABEL.
-endef
-
 define Package/libext2fs
 $(call Package/e2fsprogs/Default)
   SECTION:=libs
 define Package/libext2fs
 $(call Package/e2fsprogs/Default)
   SECTION:=libs
@@ -82,7 +47,7 @@ $(call Package/e2fsprogs/Default)
 endef
 
 define Package/libext2fs/description
 endef
 
 define Package/libext2fs/description
-libext2fs is a library which can access ext2, ext3 and ext4 filesystems.
+ libext2fs is a library which can access ext2, ext3 and ext4 filesystems.
 endef
 
 define Package/libcom_err
 endef
 
 define Package/libcom_err
@@ -93,7 +58,7 @@ $(call Package/e2fsprogs/Default)
 endef
 
 define Package/libcom_err/description
 endef
 
 define Package/libcom_err/description
-libcom_err is a library providing common error descriptions
+ libcom_err is a library providing common error descriptions
 endef
 
 define Package/tune2fs
 endef
 
 define Package/tune2fs
@@ -114,18 +79,12 @@ $(call Package/e2fsprogs)
   DEPENDS:= +e2fsprogs
 endef
 
   DEPENDS:= +e2fsprogs
 endef
 
-define Package/blkid
-$(call Package/e2fsprogs)
-  TITLE:=Command-line utility to locate/print block device attributes
-  DEPENDS:=+libuuid +libblkid +libext2fs +libcom_err +libpthread
-endef
-
 TARGET_CFLAGS += $(FPIC)
 
 CONFIGURE_ARGS += \
 TARGET_CFLAGS += $(FPIC)
 
 CONFIGURE_ARGS += \
-       --enable-elf-shlibs \
-       --disable-tls \
-       --disable-nls \
+       --enable-elf-shlibs     \
+       --disable-tls           \
+       --disable-nls           \
        --disable-rpath
 
 define Build/Prepare
        --disable-rpath
 
 define Build/Prepare
@@ -177,21 +136,6 @@ define Package/libcom_err/install
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcom_err.so.* $(1)/usr/lib/
 endef
 
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcom_err.so.* $(1)/usr/lib/
 endef
 
-define Package/libuuid/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libuuid.so.* $(1)/usr/lib/
-endef
-
-define Package/uuidgen/install
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/uuidgen $(1)/usr/bin/
-endef
-
-define Package/libblkid/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libblkid.so.* $(1)/usr/lib/
-endef
-
 define Package/libext2fs/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libext2fs.so.* $(1)/usr/lib/
 define Package/libext2fs/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libext2fs.so.* $(1)/usr/lib/
@@ -212,18 +156,9 @@ define Package/badblocks/install
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/badblocks $(1)/usr/sbin/
 endef
 
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/badblocks $(1)/usr/sbin/
 endef
 
-define Package/blkid/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/blkid $(1)/usr/sbin/
-endef
-
 $(eval $(call BuildPackage,e2fsprogs))
 $(eval $(call BuildPackage,e2fsprogs))
-$(eval $(call BuildPackage,libuuid))
-$(eval $(call BuildPackage,uuidgen))
-$(eval $(call BuildPackage,libblkid))
 $(eval $(call BuildPackage,libext2fs))
 $(eval $(call BuildPackage,libcom_err))
 $(eval $(call BuildPackage,tune2fs))
 $(eval $(call BuildPackage,resize2fs))
 $(eval $(call BuildPackage,badblocks))
 $(eval $(call BuildPackage,libext2fs))
 $(eval $(call BuildPackage,libcom_err))
 $(eval $(call BuildPackage,tune2fs))
 $(eval $(call BuildPackage,resize2fs))
 $(eval $(call BuildPackage,badblocks))
-$(eval $(call BuildPackage,blkid))