hotplug2 update - include hotplug2-init.rules from hotplug2.rules, fix permissions...
[openwrt/openwrt.git] / package / hotplug2 / Makefile
index 94aadc085334bd4785878703b2f681c08acb7bac..559732bf4c83b05e3d2337babe5ed70889e02ac5 100644 (file)
@@ -21,6 +21,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/hotplug2
   SECTION:=utils
   CATEGORY:=Utilities
+  VERSION:=0.9+r102-$(PKG_RELEASE)
   TITLE:=Dynamic device management subsystem for embedded systems
   URL:=http://isteve.bofh.cz/~isteve/hotplug2/
 endef
@@ -29,7 +30,7 @@ define Package/hotplug2/description
 Hotplug2 is a trivial replacement of some of the UDev functionality
 in a tiny pack, intended for Linux early userspace: Init RAM FS and InitRD.
 endef
-MAKE_FLAGS += CFLAGS="$(TARGET_CFLAGS) -DHAVE_RULES"
+MAKE_FLAGS += CFLAGS="$(TARGET_CFLAGS) -DHAVE_RULES -I."
 
 define Package/hotplug2/install
        $(INSTALL_DIR) $(1)/etc