ath10k-ct: adds leds support
[openwrt/openwrt.git] / package / kernel / ath10k-ct / Makefile
index 634bdf14beb3a811084f4ba2ceae9c8eb9def0b9..d39ecabf462e6c57672642a1e047809135934e2c 100644 (file)
@@ -8,14 +8,14 @@ PKG_LICENSE_FILES:=
 
 PKG_SOURCE_URL:=https://github.com/greearb/ath10k-ct.git
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2018-05-30
-PKG_SOURCE_VERSION:=127f98189ee57260ed175a60d6654a43c32a8f4b
-PKG_MIRROR_HASH:=f8856c9d950d3b12ce0d8770e56e861df14878a1b3601592205c5d51edc794ac
+PKG_SOURCE_DATE:=2018-08-22
+PKG_SOURCE_VERSION:=34954f0f333fa43827b2af67313db2b1e830bb48
+PKG_MIRROR_HASH:=aa77f388727ff2201de615c3211ab5c0b2dc5e3c041bd1cde4d6eebde0ca437a
 
 # Build the 4.13 ath10k-ct driver version.  Other options are "-4.9", or
 # leave un-defined for 4.7 kernel.  Probably this should match as closely as
 # possible to whatever mac80211 backports version is being used.
-CT_KVER="-4.13"
+CT_KVER="-4.16"
 
 PKG_MAINTAINER:=Ben Greear <greearb@candelatech.com>
 PKG_BUILD_PARALLEL:=1
@@ -37,6 +37,14 @@ define KernelPackage/ath10k-ct
   PROVIDES:=kmod-ath10k
 endef
 
+define KernelPackage/ath10k-ct/config
+
+       config ATH10K-CT_LEDS
+               bool "Enable LED support"
+               default y
+               depends on PACKAGE_kmod-ath10k-ct
+endef
+
 NOSTDINC_FLAGS = \
        -I$(PKG_BUILD_DIR) \
        -I$(STAGING_DIR)/usr/include/mac80211-backport/uapi \
@@ -77,6 +85,11 @@ ifdef CONFIG_PACKAGE_ATH_SPECTRAL
   NOSTDINC_FLAGS += -DCONFIG_ATH10K_SPECTRAL
 endif
 
+ifeq ($(CONFIG_ATH10K-CT_LEDS),y)
+  CT_MAKEDEFS += CONFIG_ATH10K_LEDS=y
+  NOSTDINC_FLAGS += -DCONFIG_ATH10K_LEDS
+endif
+
 define Build/Configure
        cp $(STAGING_DIR)/usr/include/mac80211/ath/*.h $(PKG_BUILD_DIR)
 endef