build: use mkhash to replace various quirky md5sum/openssl calls
[openwrt/openwrt.git] / package / kernel / linux / Makefile
index 7f38f3e6e263c7faf37a48e1615cf1fd79b1e83c..c2d10ec188470efb3fa1c3bb576c91aff782768f 100644 (file)
@@ -24,7 +24,7 @@ export SHELL:=/bin/sh
 include $(INCLUDE_DIR)/package.mk
 
 ifeq ($(DUMP),)
-  STAMP_BUILT:=$(STAMP_BUILT)_$(firstword $(shell $(SCRIPT_DIR)/kconfig.pl $(LINUX_DIR)/.config | md5sum))
+  STAMP_BUILT:=$(STAMP_BUILT)_$(shell $(SCRIPT_DIR)/kconfig.pl $(LINUX_DIR)/.config | mkhash md5)
   -include $(LINUX_DIR)/.config
 endif