generic: add linux 4.1 support
[openwrt/openwrt.git] / package / kernel / linux / modules / can.mk
index 9245490a203dd6383958c8d59156c645f89da685..f9490b40d450115ed187ced519c85f2ba40de695 100644 (file)
@@ -240,7 +240,7 @@ $(eval $(call KernelPackage,can-c-can))
 define KernelPackage/can-c-can-platform
   TITLE:=Platform Bus based BOSCH C_CAN/D_CAN driver
   KCONFIG:=CONFIG_CAN_C_CAN_PLATFORM
-  DEPENDS:=kmod-can-c-can
+  DEPENDS:=kmod-can-c-can +LINUX_4_1:kmod-regmap
   FILES:=$(LINUX_DIR)/drivers/net/can/c_can/c_can_platform.ko
   AUTOLOAD:=$(call AutoProbe,c_can_platform)
   $(call AddDepends/can)