kernel: Fix F2FS module dependencies
[openwrt/openwrt.git] / package / kernel / linux / modules / fs.mk
index 4d69d9b1408da1d09fd80d6c77fb70f026d0b0ba..610d1b58a1ae453409eea2704c5037074f86c4ae 100644 (file)
@@ -200,6 +200,7 @@ $(eval $(call KernelPackage,fs-ext4))
 define KernelPackage/fs-f2fs
   SUBMENU:=$(FS_MENU)
   TITLE:=F2FS filesystem support
+  DEPENDS:= +kmod-crypto-hash +kmod-crypto-crc32
   KCONFIG:= \
        CONFIG_F2FS_FS \
        CONFIG_F2FS_STAT_FS=y \