kernel: remove kmod-appletalk
[openwrt/openwrt.git] / package / kernel / linux / modules / netsupport.mk
index 836034ad122574b287307985cc2ff5f941052903..eb0657d58f7f71e58956aa9d582dd7cd12ea0bfa 100644 (file)
@@ -42,28 +42,6 @@ endef
 $(eval $(call KernelPackage,atmtcp))
 
 
-define KernelPackage/appletalk
-  SUBMENU:=$(NETWORK_SUPPORT_MENU)
-  TITLE:=Appletalk protocol support
-  KCONFIG:= \
-       CONFIG_ATALK \
-       CONFIG_DEV_APPLETALK \
-       CONFIG_IPDDP \
-       CONFIG_IPDDP_ENCAP=y \
-       CONFIG_IPDDP_DECAP=y
-  FILES:= \
-       $(LINUX_DIR)/net/appletalk/appletalk.ko \
-       $(LINUX_DIR)/drivers/net/appletalk/ipddp.ko
-  AUTOLOAD:=$(call AutoLoad,40,appletalk ipddp)
-endef
-
-define KernelPackage/appletalk/description
- Kernel module for AppleTalk protocol.
-endef
-
-$(eval $(call KernelPackage,appletalk))
-
-
 define KernelPackage/bonding
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=Ethernet bonding driver
@@ -434,6 +412,28 @@ endef
 $(eval $(call KernelPackage,sit))
 
 
+define KernelPackage/fou
+  SUBMENU:=$(NETWORK_SUPPORT_MENU)
+  TITLE:=FOU and GUE decapsulation
+  DEPENDS:= \
+       +kmod-iptunnel \
+       +kmod-udptunnel4 \
+       +IPV6:kmod-udptunnel6
+  KCONFIG:= \
+       CONFIG_NET_FOU \
+       CONFIG_NET_FOU_IP_TUNNELS=y
+  FILES:=$(LINUX_DIR)/net/ipv4/fou.ko
+  AUTOLOAD:=$(call AutoProbe,fou)
+endef
+
+define KernelPackage/fou/description
+ Kernel module for FOU (Foo over UDP) and GUE (Generic UDP Encapsulation) tunnelling.
+ Requires Kernel 3.18 or newer.
+endef
+
+$(eval $(call KernelPackage,fou))
+
+
 define KernelPackage/ip6-tunnel
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=IP-in-IPv6 tunnelling
@@ -729,6 +729,7 @@ define KernelPackage/sched
        CONFIG_NET_SCH_DSMARK \
        CONFIG_NET_SCH_FIFO \
        CONFIG_NET_SCH_GRED \
+       CONFIG_NET_SCH_MULTIQ \
        CONFIG_NET_SCH_PRIO \
        CONFIG_NET_SCH_RED \
        CONFIG_NET_SCH_SFQ \