kernel: kmod-geneve: kmod for Geneve tunneling
[openwrt/openwrt.git] / package / kernel / linux / modules / netsupport.mk
index d31d53304a64482692ea4b88f169db123c0cbc72..ff7672063688c7da53fc45c191147b1d52fe9827 100644 (file)
@@ -42,28 +42,6 @@ endef
 $(eval $(call KernelPackage,atmtcp))
 
 
-define KernelPackage/appletalk
-  SUBMENU:=$(NETWORK_SUPPORT_MENU)
-  TITLE:=Appletalk protocol support
-  KCONFIG:= \
-       CONFIG_ATALK \
-       CONFIG_DEV_APPLETALK \
-       CONFIG_IPDDP \
-       CONFIG_IPDDP_ENCAP=y \
-       CONFIG_IPDDP_DECAP=y
-  FILES:= \
-       $(LINUX_DIR)/net/appletalk/appletalk.ko \
-       $(LINUX_DIR)/drivers/net/appletalk/ipddp.ko
-  AUTOLOAD:=$(call AutoLoad,40,appletalk ipddp)
-endef
-
-define KernelPackage/appletalk/description
- Kernel module for AppleTalk protocol.
-endef
-
-$(eval $(call KernelPackage,appletalk))
-
-
 define KernelPackage/bonding
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=Ethernet bonding driver
@@ -127,6 +105,29 @@ endef
 
 $(eval $(call KernelPackage,vxlan))
 
+
+define KernelPackage/geneve
+  SUBMENU:=$(NETWORK_SUPPORT_MENU)
+  TITLE:=Generic Network Virtualization Encapsulation (Geneve) support
+  DEPENDS:= \
+       +kmod-iptunnel \
+       +kmod-udptunnel4 \
+       +IPV6:kmod-udptunnel6
+  KCONFIG:=CONFIG_GENEVE
+  FILES:= \
+       $(LINUX_DIR)/net/ipv4/geneve.ko@le4.1 \
+       $(LINUX_DIR)/drivers/net/geneve.ko@ge4.2
+  AUTOLOAD:=$(call AutoLoad,13,geneve)
+endef
+
+define KernelPackage/geneve/description
+ Kernel module for supporting Geneve in the Kernel.
+ Requires Kernel 3.18 or newer.
+endef
+
+$(eval $(call KernelPackage,geneve))
+
+
 define KernelPackage/capi
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=CAPI (ISDN) Support