kernel: sound: add missing symbol to sound-soc-core
[openwrt/openwrt.git] / package / kernel / linux / modules / sound.mk
index de5d8fc2c62e59041dae7406241b709eba21712f..c83e553d8ffe5a194dc14011bbe68a453123146b 100644 (file)
@@ -24,7 +24,8 @@ SOUNDCORE_FILES ?= \
        $(LINUX_DIR)/sound/soundcore.ko \
        $(LINUX_DIR)/sound/core/snd.ko \
        $(LINUX_DIR)/sound/core/snd-hwdep.ko \
-       $(LINUX_DIR)/sound/core/seq/snd-seq-device.ko \
+       $(LINUX_DIR)/sound/core/seq/snd-seq-device.ko@lt4.13 \
+       $(LINUX_DIR)/sound/core/snd-seq-device.ko@ge4.13 \
        $(LINUX_DIR)/sound/core/snd-rawmidi.ko \
        $(LINUX_DIR)/sound/core/snd-timer.ko \
        $(LINUX_DIR)/sound/core/snd-pcm.ko \
@@ -67,7 +68,7 @@ define KernelPackage/sound-core/uml
   FILES:= \
        $(LINUX_DIR)/sound/soundcore.ko \
        $(LINUX_DIR)/arch/um/drivers/hostaudio.ko
-  AUTOLOAD:=$(call AutoLoad,30,soundcore hostaudio)
+  AUTOLOAD+=$(call AutoLoad,30,soundcore hostaudio)
 endef
 
 define KernelPackage/sound-core/description
@@ -134,6 +135,22 @@ endef
 $(eval $(call KernelPackage,sound-seq))
 
 
+define KernelPackage/sound-ens1371
+  TITLE:=(Creative) Ensoniq AudioPCI 1371
+  KCONFIG:=CONFIG_SND_ENS1371
+  DEPENDS:=@PCI_SUPPORT +kmod-ac97
+  FILES:=$(LINUX_DIR)/sound/pci/snd-ens1371.ko
+  AUTOLOAD:=$(call AutoLoad,36,snd-ens1371)
+  $(call AddDepends/sound)
+endef
+
+define KernelPackage/sound-ens1371/description
+ support for (Creative) Ensoniq AudioPCI 1371 chips
+endef
+
+$(eval $(call KernelPackage,sound-ens1371))
+
+
 define KernelPackage/sound-i8x0
   TITLE:=Intel/SiS/nVidia/AMD/ALi AC97 Controller
   DEPENDS:=+kmod-ac97
@@ -171,9 +188,10 @@ $(eval $(call KernelPackage,sound-via82xx))
 
 define KernelPackage/sound-soc-core
   TITLE:=SoC sound support
-  DEPENDS:=+kmod-regmap +kmod-ac97
+  DEPENDS:=+kmod-regmap-core +kmod-ac97
   KCONFIG:= \
        CONFIG_SND_SOC \
+       CONFIG_SND_SOC_ADI=n \
        CONFIG_SND_SOC_DMAENGINE_PCM=y \
        CONFIG_SND_SOC_ALL_CODECS=n
   FILES:=$(LINUX_DIR)/sound/soc/snd-soc-core.ko
@@ -304,7 +322,7 @@ define KernelPackage/sound-hda-core
        $(LINUX_DIR)/sound/pci/hda/snd-hda-codec.ko \
        $(LINUX_DIR)/sound/pci/hda/snd-hda-codec-generic.ko
   AUTOLOAD:=$(call AutoProbe,snd-hda-core@ge4.1 snd-hda-codec snd-hda-codec-generic)
-  $(call AddDepends/sound,+kmod-regmap)
+  $(call AddDepends/sound,+kmod-regmap-core)
 endef
 
 define KernelPackage/sound-hda-core/description