build: scan.mk: consider KernelPackage pattern as well
[openwrt/openwrt.git] / package / kernel / mac80211 / Makefile
index 8391a8cf24971ec51709c4a3628aeb43c98101d9..a5e56d98583fb3b2dd2755d9fc0ba3bc6d5873b3 100644 (file)
@@ -205,7 +205,7 @@ define KernelPackage/ath5k
   $(call KernelPackage/mac80211/Default)
   TITLE:=Atheros 5xxx wireless cards support
   URL:=https://wireless.wiki.kernel.org/en/users/drivers/ath5k
-  DEPENDS+= @PCI_SUPPORT||@TARGET_ath25 +kmod-ath
+  DEPENDS+= @PCI_SUPPORT||@TARGET_ath25 +kmod-ath +@DRIVER_11W_SUPPORT
   FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/ath/ath5k/ath5k.ko
   AUTOLOAD:=$(call AutoProbe,ath5k)
 endef