package/kernel: remove SetDepends not needed anymore
[openwrt/openwrt.git] / package / kernel / modules / 001-depends.mk
index 238799e2e54c6d4dcd469598e203d8f36e187986..93aaeb33fb6e1d27a8b63597db5f610770da0168 100644 (file)
@@ -1,37 +1,20 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
-# XXX: xburst has CONFIG_CRC16=y because of CONFIG_UBIFS_FS=y
-
-define SetDepends/crc16
-  DEPENDS:= @!TARGET_xburst
-endef
-
 define AddDepends/crc16
-  DEPENDS+= +!TARGET_xburst:kmod-crc16 $(1)
-endef
-
-
-define SetDepends/hid
-  DEPENDS:= @!TARGET_x86
+  DEPENDS+= +kmod-crc16 $(1)
 endef
 
 define AddDepends/hid
-  DEPENDS+= +!TARGET_x86:kmod-hid $(1)
-
-endef
-
-
-define SetDepends/input
-  DEPENDS:= @!(TARGET_x86_generic||TARGET_x86_kvm_guest)
+  DEPENDS+= +kmod-hid $(1)
 endef
 
 define AddDepends/input
-  DEPENDS+= +!(TARGET_x86_generic||TARGET_x86_kvm_guest):kmod-input-core $(1)
+  DEPENDS+= +kmod-input-core $(1)
 endef