kmod-ocf-hifn7751 depends on PCI, spotted by buildbot
[openwrt/openwrt.git] / package / kernel / modules / crypto.mk
index f675c5aacfa688d479d0bb6f62414570a9fa54ae..133c790ee056552704aebaf3b17f5597d6a65e6b 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 CRYPTO_MENU:=Cryptographic API modules
 
@@ -15,30 +14,24 @@ CRYPTO_MENU:=Cryptographic API modules
 #  - sha1 > sha1_generic (2.6.24)
 #  - sha256 > sha256_generic (2.6.24)
 #  - sha512 > sha512_generic (2.6.26)
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.24)),1)
+ifneq ($(CONFIG_LINUX_2_6),)
   CRYPTO_GENERIC:=_generic
   AES_SUFFIX:=$(CRYPTO_GENERIC)
   DES_SUFFIX:=$(CRYPTO_GENERIC)
   SHA1_SUFFIX:=$(CRYPTO_GENERIC)
   SHA256_SUFFIX:=$(CRYPTO_GENERIC)
-endif
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.25)),1)
-  CRYPTO_PREFIX:=crypto_
-  BLKCIPHER_PREFIX:=$(CRYPTO_PREFIX)
-endif
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.26)),1)
   SHA512_SUFFIX:=$(CRYPTO_GENERIC)
 endif
 
 CRYPTO_MODULES = \
        ALGAPI=crypto_algapi \
-       AEAD=aead \
-       BLKCIPHER=$(BLKCIPHER_PREFIX)blkcipher \
-       MANAGER=cryptomgr \
-       HASH=crypto_hash \
+       AEAD2=aead \
+       PCOMP=pcompress \
+       BLKCIPHER2=crypto_blkcipher \
+       HASH2=crypto_hash \
+       MANAGER2=cryptomgr \
        CBC=cbc \
        ECB=ecb \
-       HMAC=hmac \
        DEFLATE=deflate
 
 crypto_confvar=CONFIG_CRYPTO_$(word 1,$(subst =,$(space),$(1)))
@@ -50,7 +43,7 @@ crypto_name=$(if $(findstring y,$($(call crypto_confvar,$(1)))),,$(word 2,$(subs
 define KernelPackage/crypto-core
   SUBMENU:=$(CRYPTO_MENU)
   TITLE:=Core CryptoAPI modules
-  KCONFIG:=CONFIG_CRYPTO=y $(foreach mod,$(CRYPTO_MODULES),$(call crypto_confvar,$(mod)))
+  KCONFIG:=CONFIG_CRYPTO=y CONFIG_CRYPTO_HMAC $(foreach mod,$(CRYPTO_MODULES),$(call crypto_confvar,$(mod)))
   FILES:=$(foreach mod,$(CRYPTO_MODULES),$(call crypto_file,$(mod)))
   AUTOLOAD:=$(call AutoLoad,01,$(foreach mod,$(CRYPTO_MODULES),$(call crypto_name,$(mod))))
 endef
@@ -63,10 +56,15 @@ endef
 $(eval $(call KernelPackage,crypto-core))
 
 
-define KernelPackage/crypto-hw-padlock
+define AddDepends/crypto
   SUBMENU:=$(CRYPTO_MENU)
+  DEPENDS+=kmod-crypto-core $(1)
+endef
+
+
+define KernelPackage/crypto-hw-padlock
   TITLE:=VIA PadLock ACE with AES/SHA hw crypto module
-  DEPENDS:=+kmod-crypto-core
+  DEPENDS:=@LINUX_2_6
   KCONFIG:= \
        CONFIG_CRYPTO_HW=y \
        CONFIG_CRYPTO_DEV_PADLOCK \
@@ -76,48 +74,51 @@ define KernelPackage/crypto-hw-padlock
        $(LINUX_DIR)/drivers/crypto/padlock-aes.$(LINUX_KMOD_SUFFIX) \
        $(LINUX_DIR)/drivers/crypto/padlock-sha.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,09,padlock-aes padlock-sha)
+  $(call AddDepends/crypto)
 endef
 
 $(eval $(call KernelPackage,crypto-hw-padlock))
 
 
 define KernelPackage/crypto-hw-geode
-  SUBMENU:=$(CRYPTO_MENU)
   TITLE:=AMD Geode hardware crypto module
-  DEPENDS:=+kmod-crypto-core
+  DEPENDS:=@LINUX_2_6
   KCONFIG:= \
        CONFIG_CRYPTO_HW=y \
        CONFIG_CRYPTO_DEV_GEODE
   FILES:=$(LINUX_DIR)/drivers/crypto/geode-aes.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,09,geode-aes)
+  $(call AddDepends/crypto)
 endef
 
 $(eval $(call KernelPackage,crypto-hw-geode))
 
 
 define KernelPackage/crypto-hw-hifn-795x
-  SUBMENU:=$(CRYPTO_MENU)
   TITLE:=HIFN 795x crypto accelerator
-  DEPENDS:=+kmod-crypto-core +kmod-crypto-des
+  DEPENDS:=@LINUX_2_6 @!TARGET_ubicom32
   KCONFIG:= \
        CONFIG_CRYPTO_HW=y \
+       CONFIG_HW_RANDOM=y \
        CONFIG_CRYPTO_DEV_HIFN_795X \
        CONFIG_CRYPTO_DEV_HIFN_795X_RNG=y
   FILES:=$(LINUX_DIR)/drivers/crypto/hifn_795x.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,09,hifn_795x)
+  $(call AddDepends/crypto,+kmod-crypto-des)
 endef
 
 $(eval $(call KernelPackage,crypto-hw-hifn-795x))
 
 
 define KernelPackage/crypto-hw-ixp4xx
-  SUBMENU:=$(CRYPTO_MENU)
   TITLE:=Intel IXP4xx hardware crypto module
-  DEPENDS:= \
-       @TARGET_ixp4xx +kmod-crypto-core +kmod-crypto-des +kmod-crypto-authenc
-  KCONFIG:= CONFIG_CRYPTO_DEV_IXP4XX
+  DEPENDS:=@TARGET_ixp4xx
+  KCONFIG:= \
+       CONFIG_CRYPTO_HW=y \
+       CONFIG_CRYPTO_DEV_IXP4XX
   FILES:=$(LINUX_DIR)/drivers/crypto/ixp4xx_crypto.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,90,ixp4xx_crypto)
+  $(call AddDepends/crypto,+kmod-crypto-authenc +kmod-crypto-des)
 endef
 
 define KernelPackage/crypto-hw-ixp4xx/description
@@ -127,16 +128,33 @@ endef
 $(eval $(call KernelPackage,crypto-hw-ixp4xx))
 
 
+define KernelPackage/crypto-hw-ppc4xx
+  TITLE:=AMCC PPC4xx hardware crypto module
+  DEPENDS:=@TARGET_ppc40x||TARGET_ppc44x
+  KCONFIG:= \
+       CONFIG_CRYPTO_HW=y \
+       CONFIG_CRYPTO_DEV_PPC4XX
+  FILES:=$(LINUX_DIR)/drivers/crypto/amcc/crypto4xx.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,90,crypto4xx)
+  $(call AddDepends/crypto)
+endef
+
+define KernelPackage/crypto-hw-ppc4xx/description
+  Kernel support for the AMCC PPC4xx HW crypto engine.
+endef
+
+$(eval $(call KernelPackage,crypto-hw-ppc4xx))
+
+
 define KernelPackage/crypto-aes
-  SUBMENU:=$(CRYPTO_MENU)
   TITLE:=AES cipher CryptoAPI module
-  DEPENDS:=+kmod-crypto-core
   KCONFIG:=CONFIG_CRYPTO_AES CONFIG_CRYPTO_AES_586
   FILES:=$(LINUX_DIR)/crypto/aes$(AES_SUFFIX).$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,09,aes$(AES_SUFFIX))
+  $(call AddDepends/crypto)
 endef
 
-define KernelPackage/crypto-aes/x86-2.6
+define KernelPackage/crypto-aes/x86
   FILES+=$(LINUX_DIR)/arch/x86/crypto/aes-i586.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,09,aes$(AES_SUFFIX) aes-i586)
 endef
@@ -145,92 +163,83 @@ $(eval $(call KernelPackage,crypto-aes))
 
 
 define KernelPackage/crypto-arc4
-  SUBMENU:=$(CRYPTO_MENU)
   TITLE:=ARC4 (RC4) cipher CryptoAPI module
-  DEPENDS:=+kmod-crypto-core
   KCONFIG:=CONFIG_CRYPTO_ARC4
   FILES:=$(LINUX_DIR)/crypto/arc4.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,09,arc4)
+  $(call AddDepends/crypto)
 endef
 
 $(eval $(call KernelPackage,crypto-arc4))
 
 
 define KernelPackage/crypto-authenc
-  SUBMENU:=$(CRYPTO_MENU)
   TITLE:=Combined mode wrapper for IPsec
-  DEPENDS:=+kmod-crypto-core
   KCONFIG:=CONFIG_CRYPTO_AUTHENC
   FILES:=$(LINUX_DIR)/crypto/authenc.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,09,authenc)
+  $(call AddDepends/crypto)
 endef
 
 $(eval $(call KernelPackage,crypto-authenc))
 
 define KernelPackage/crypto-des
-  SUBMENU:=$(CRYPTO_MENU)
   TITLE:=DES/3DES cipher CryptoAPI module
-  DEPENDS:=+kmod-crypto-core
   KCONFIG:=CONFIG_CRYPTO_DES
   FILES:=$(LINUX_DIR)/crypto/des$(DES_SUFFIX).$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,09,des$(DES_SUFFIX))
+  $(call AddDepends/crypto)
 endef
 
 $(eval $(call KernelPackage,crypto-des))
 
 
 define KernelPackage/crypto-hmac
-  SUBMENU:=$(CRYPTO_MENU)
   TITLE:=HMAC digest CryptoAPI module
-  DEPENDS:=+kmod-crypto-core
   KCONFIG:=CONFIG_CRYPTO_HMAC
   FILES:=$(LINUX_DIR)/crypto/hmac.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,09,hmac)
+  $(call AddDepends/crypto)
 endef
 
 $(eval $(call KernelPackage,crypto-hmac))
 
 
 define KernelPackage/crypto-md5
-  SUBMENU:=$(CRYPTO_MENU)
   TITLE:=MD5 digest CryptoAPI module
-  DEPENDS:=+kmod-crypto-core
   KCONFIG:=CONFIG_CRYPTO_MD5
   FILES:=$(LINUX_DIR)/crypto/md5.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,09,md5)
+  $(call AddDepends/crypto)
 endef
 
 $(eval $(call KernelPackage,crypto-md5))
 
 
 define KernelPackage/crypto-michael-mic
-  SUBMENU:=$(CRYPTO_MENU)
   TITLE:=Michael MIC keyed digest CryptoAPI module
-  DEPENDS:=+kmod-crypto-core
   KCONFIG:=CONFIG_CRYPTO_MICHAEL_MIC
   FILES:=$(LINUX_DIR)/crypto/michael_mic.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,09,michael_mic)
+  $(call AddDepends/crypto)
 endef
 
 $(eval $(call KernelPackage,crypto-michael-mic))
 
 
 define KernelPackage/crypto-sha1
-  SUBMENU:=$(CRYPTO_MENU)
   TITLE:=SHA1 digest CryptoAPI module
-  DEPENDS:=+kmod-crypto-core
   KCONFIG:=CONFIG_CRYPTO_SHA1
   FILES:=$(LINUX_DIR)/crypto/sha1$(SHA1_SUFFIX).$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,09,sha1$(SHA1_SUFFIX))
+  $(call AddDepends/crypto)
 endef
 
 $(eval $(call KernelPackage,crypto-sha1))
 
 
 define KernelPackage/crypto-misc
-  SUBMENU:=$(CRYPTO_MENU)
   TITLE:=Other CryptoAPI modules
-  DEPENDS:=+kmod-crypto-core
   KCONFIG:= \
        CONFIG_CRYPTO_ANUBIS \
        CONFIG_CRYPTO_BLOWFISH \
@@ -247,6 +256,7 @@ define KernelPackage/crypto-misc
        CONFIG_CRYPTO_TEA \
        CONFIG_CRYPTO_TGR192 \
        CONFIG_CRYPTO_TWOFISH \
+       CONFIG_CRYPTO_TWOFISH_COMMON \
        CONFIG_CRYPTO_TWOFISH_586 \
        CONFIG_CRYPTO_WP512
   FILES:= \
@@ -262,6 +272,7 @@ define KernelPackage/crypto-misc
        $(LINUX_DIR)/crypto/tea.$(LINUX_KMOD_SUFFIX) \
        $(LINUX_DIR)/crypto/twofish.$(LINUX_KMOD_SUFFIX) \
        $(LINUX_DIR)/crypto/wp512.$(LINUX_KMOD_SUFFIX)
+  $(call AddDepends/crypto)
 endef
 
 define KernelPackage/crypto-misc/2.6
@@ -269,15 +280,20 @@ define KernelPackage/crypto-misc/2.6
        $(LINUX_DIR)/crypto/camellia.$(LINUX_KMOD_SUFFIX) \
        $(LINUX_DIR)/crypto/crc32c.$(LINUX_KMOD_SUFFIX) \
        $(LINUX_DIR)/crypto/fcrypt.$(LINUX_KMOD_SUFFIX) \
-       $(LINUX_DIR)/crypto/tgr192.$(LINUX_KMOD_SUFFIX)
+       $(LINUX_DIR)/crypto/tgr192.$(LINUX_KMOD_SUFFIX) \
+       $(LINUX_DIR)/crypto/twofish_common.$(LINUX_KMOD_SUFFIX)
+endef
+
+define KernelPackage/crypto-misc/x86
+  FILES+=$(LINUX_DIR)/arch/x86/crypto/twofish-i586.$(LINUX_KMOD_SUFFIX)
 endef
 
 $(eval $(call KernelPackage,crypto-misc))
 
+
 define KernelPackage/crypto-ocf
-  SUBMENU:=$(CRYPTO_MENU)
   TITLE:=OCF modules
-  DEPENDS:=+kmod-crypto-core @!TARGET_uml
+  DEPENDS:=+@OPENSSL_ENGINE @!TARGET_uml
   KCONFIG:= \
        CONFIG_OCF_OCF \
        CONFIG_OCF_CRYPTODEV \
@@ -293,29 +309,52 @@ define KernelPackage/crypto-ocf
        cryptodev \
        cryptosoft \
   )
+  $(call AddDepends/crypto)
 endef
 
 $(eval $(call KernelPackage,crypto-ocf))
 
 
+define KernelPackage/crypto-ocf-hifn7751
+  TITLE:=OCF support for Hifn 6500/7751/7811/795x, Invertex AEON and NetSec 7751 devices
+  DEPENDS:=+@OPENSSL_ENGINE @PCI_SUPPORT @!TARGET_uml kmod-crypto-ocf
+  KCONFIG:=CONFIG_OCF_HIFN
+  FILES:=$(LINUX_DIR)/crypto/ocf/hifn/hifn7751.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,10,hifn7751)
+  $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-ocf-hifn7751))
+
+
+define KernelPackage/crypto-ocf-hifnhipp
+  TITLE:=OCF support for Hifn 7855/8155 devices
+  DEPENDS:=+@OPENSSL_ENGINE @!TARGET_uml kmod-crypto-ocf
+  KCONFIG:=CONFIG_OCF_HIFNHIPP
+  FILES:=$(LINUX_DIR)/crypto/ocf/hifn/hifnHIPP.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,10,hifnhipp)
+  $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-ocf-hifnhipp))
+
+
 define KernelPackage/crypto-null
-  SUBMENU:=$(CRYPTO_MENU)
   TITLE:=Null CryptoAPI module
-  DEPENDS:=+kmod-crypto-core
   KCONFIG:=CONFIG_CRYPTO_NULL
   FILES:=$(LINUX_DIR)/crypto/crypto_null.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,09,crypto_null)
+  $(call AddDepends/crypto)
 endef
 
 $(eval $(call KernelPackage,crypto-null))
 
 
 define KernelPackage/crypto-test
-  SUBMENU:=$(CRYPTO_MENU)
   TITLE:=Test CryptoAPI module
-  DEPENDS:=+kmod-crypto-core
   KCONFIG:=CONFIG_CRYPTO_TEST
   FILES:=$(LINUX_DIR)/crypto/tcrypt.$(LINUX_KMOD_SUFFIX)
+  $(call AddDepends/crypto)
 endef
 
 $(eval $(call KernelPackage,crypto-test))