add missing rtc-lib module to rtc-core
[openwrt/openwrt.git] / package / kernel / modules / other.mk
index 6340e6f413deb7d2f8cfa50c44396e7821c25054..79ec19084385743250cd350d392c0bc63dc009fe 100644 (file)
@@ -71,7 +71,11 @@ define KernelPackage/eeprom-93cx6
   TITLE:=EEPROM 93CX6 support
   DEPENDS:=@LINUX_2_6
   KCONFIG:=CONFIG_EEPROM_93CX6
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.29)),1)
+  FILES:=$(LINUX_DIR)/drivers/misc/eeprom/eeprom_93cx6.$(LINUX_KMOD_SUFFIX)
+else
   FILES:=$(LINUX_DIR)/drivers/misc/eeprom_93cx6.$(LINUX_KMOD_SUFFIX)
+endif
   AUTOLOAD:=$(call AutoLoad,20,eeprom_93cx6)
 endef
 
@@ -213,6 +217,7 @@ define KernelPackage/ssb
   KCONFIG:=\
        CONFIG_SSB \
        CONFIG_SSB_B43_PCI_BRIDGE=y \
+       CONFIG_SSB_DRIVER_MIPS=n \
        CONFIG_SSB_DRIVER_PCICORE=y \
        CONFIG_SSB_DRIVER_PCICORE_POSSIBLE=y \
        CONFIG_SSB_PCIHOST=y \
@@ -855,7 +860,7 @@ $(eval $(call KernelPackage,textsearch))
 define KernelPackage/rfkill
   SUBMENU:=$(OTHER_MENU)
   TITLE:=RF switch subsystem support
-  DEPENDS:=@LINUX_2_6 @!LINUX_2_6_21 @!TARGET_rb532 @!TARGET_avr32 @!TARGET_brcm47xx @!TARGET_s3c24xx @!TARGET_ifxmips @!TARGET_atheros @!TARGET_adm5120 @!TARGET_ar7 @!TARGET_ppc40x @!TARGET_ixp4xx @!TARGET_rdc
+  DEPENDS:=@LINUX_2_6 @!LINUX_2_6_21 @!TARGET_rb532 @!TARGET_avr32 @!TARGET_brcm47xx @!TARGET_s3c24xx @!TARGET_ifxmips @!TARGET_atheros @!TARGET_adm5120 @!TARGET_ar7 @!TARGET_ppc40x @!TARGET_ixp4xx @!TARGET_rdc @!TARGET_uml
   KCONFIG:= \
     CONFIG_RFKILL \
     CONFIG_RFKILL_INPUT \
@@ -873,3 +878,39 @@ endef
 
 $(eval $(call KernelPackage,rfkill))
 
+
+define KernelPackage/rtc-core
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Kernel support for RTC devices
+  DEPENDS:=@LINUX_2_6
+  KCONFIG:= \
+       CONFIG_RTC_CLASS \
+       CONFIG_RTC_LIB
+       CONFIG_RTC_HCTOSYS=y \
+       CONFIG_RTC_HCTOSYS_DEVICE=rtc0
+  FILES:= \
+       $(LINUX_DIR)/drivers/rtc/rtc-core.$(LINUX_KMOD_SUFFIX) \
+       $(LINUX_DIR)/drivers/rtc/rtc-lib.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,30,rtc-lib rtc-core)
+endef
+
+define KernelPackage/rtc-core/description
+ Kernel module for the RTC devices.
+endef
+
+$(eval $(call KernelPackage,rtc-core))
+
+define KernelPackage/rtc-m48t86
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=RTC M48T86 / Dallas DS12887
+  DEPENDS:=+kmod-rtc-core
+  KCONFIG:=CONFIG_RTC_DRV_M48T86
+  FILES:=$(LINUX_DIR)/drivers/rtc/rtc-m48t86.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,31,rtc-m48t86)
+endef
+
+define KernelPackage/rtc-m48t86/description
+  Kernel support for the RTC device M48T86 / Dallas DS12887
+endef
+
+$(eval $(call KernelPackage,rtc-m48t86))