usb-core: Add dependency to nls-base (#5973)
[openwrt/openwrt.git] / package / kernel / modules / usb.mk
index 8ce61f0f92d39a15c7ce7ca542bcf1c9245e77bc..8317161724ca57a7894ad5ded1b738f1405fefaf 100644 (file)
@@ -30,7 +30,7 @@ endef
 define KernelPackage/usb-core
   SUBMENU:=$(USB_MENU)
   TITLE:=Support for USB
-  DEPENDS:=@USB_SUPPORT
+  DEPENDS:=@USB_SUPPORT +LINUX_2_6_31:kmod-nls-base
   KCONFIG:=CONFIG_USB
   AUTOLOAD:=$(call AutoLoad,20,usbcore)
 endef
@@ -149,6 +149,20 @@ endef
 
 $(eval $(call KernelPackage,usb-etrax))
 
+define KernelPackage/usb-octeon
+  $(call usbdep,@TARGET_octeon)
+  TITLE:=Support for the Octeon USB OTG controller
+  KCONFIG:=CONFIG_USB_DWC_OTG
+  FILES:=$(LINUX_DIR)/drivers/usb/host/dwc_otg/dwc_otg.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,50,dwc_otg)
+endef
+
+define KernelPackage/usb-octeon/description
+  Kernel support for the Octeon USB host controller
+endef
+
+$(eval $(call KernelPackage,usb-octeon))
+
 
 define KernelPackage/usb2
   $(call usbdep,)