usb-core: Add dependency to nls-base (#5973)
[openwrt/openwrt.git] / package / kernel / modules / usb.mk
index b0dd0c6c808598c4b98c105a9cbb5f47ed581b88..8317161724ca57a7894ad5ded1b738f1405fefaf 100644 (file)
@@ -30,7 +30,7 @@ endef
 define KernelPackage/usb-core
   SUBMENU:=$(USB_MENU)
   TITLE:=Support for USB
-  DEPENDS:=@USB_SUPPORT
+  DEPENDS:=@USB_SUPPORT +LINUX_2_6_31:kmod-nls-base
   KCONFIG:=CONFIG_USB
   AUTOLOAD:=$(call AutoLoad,20,usbcore)
 endef
@@ -134,6 +134,35 @@ endef
 
 $(eval $(call KernelPackage,usb-adm5120))
 
+define KernelPackage/usb-etrax
+  $(call usbdep,@TARGET_etrax)
+  TITLE:=Support for the ETRAX USB host controller
+  KCONFIG:=CONFIG_ETRAX_USB_HOST \
+       CONFIG_ETRAX_USB_HOST_PORT1=y CONFIG_ETRAX_USB_HOST_PORT2=y
+  FILES:=$(LINUX_DIR)/drivers/usb/host/hc-crisv10.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,50,hc-crisv10)
+endef
+
+define KernelPackage/usb-etrax/description
+ Kernel support for the ETRAX USB host controller
+endef
+
+$(eval $(call KernelPackage,usb-etrax))
+
+define KernelPackage/usb-octeon
+  $(call usbdep,@TARGET_octeon)
+  TITLE:=Support for the Octeon USB OTG controller
+  KCONFIG:=CONFIG_USB_DWC_OTG
+  FILES:=$(LINUX_DIR)/drivers/usb/host/dwc_otg/dwc_otg.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,50,dwc_otg)
+endef
+
+define KernelPackage/usb-octeon/description
+  Kernel support for the Octeon USB host controller
+endef
+
+$(eval $(call KernelPackage,usb-octeon))
+
 
 define KernelPackage/usb2
   $(call usbdep,)
@@ -391,6 +420,22 @@ endef
 $(eval $(call KernelPackage,usb-serial-sierrawireless))
 
 
+define KernelPackage/usb-serial-motorola-phone
+  $(call usbdep,kmod-usb-serial)
+  TITLE:=Support for Motorola usb phone
+  KCONFIG:=CONFIG_USB_SERIAL_MOTOROLA
+  FILES:=$(LINUX_DIR)/drivers/usb/serial/moto_modem.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,65,moto_modem)
+endef
+
+define KernelPackage/usb-serial-motorola-phone/description
+ Kernel support for Motorola usb phone
+endef
+
+$(eval $(call KernelPackage,usb-serial-motorola-phone))
+
+
+
 define KernelPackage/usb-serial-visor
   $(call usbdep,kmod-usb-serial)
   TITLE:=Support for Handspring Visor devices
@@ -621,6 +666,34 @@ endef
 $(eval $(call KernelPackage,usb-net-pegasus))
 
 
+define KernelPackage/usb-net-mcs7830
+  $(call usbdep,kmod-usb-net @LINUX_2_6)
+  TITLE:=Kernel module for USB-to-Ethernet MCS7830 convertors
+  KCONFIG:=CONFIG_USB_NET_MCS7830
+  FILES:=$(LINUX_DIR)/drivers/$(USBNET_DIR)/mcs7830.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,61,mcs7830)
+endef
+
+define KernelPackage/usb-net-mcs7830/description
+ Kernel module for USB-to-Ethernet MCS7830 convertors
+endef
+
+$(eval $(call KernelPackage,usb-net-mcs7830))
+
+define KernelPackage/usb-net-dm9601-ether
+  $(call usbdep,kmod-usb-net @LINUX_2_6)
+  TITLE:=Support for DM9601 ethernet connections
+  KCONFIG:=CONFIG_USB_NET_DM9601
+  FILES:=$(LINUX_DIR)/drivers/$(USBNET_DIR)/dm9601.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,61,dm9601)
+endef
+
+define KernelPackage/usb-net-dm9601-ether/description
+  Kernel support for USB DM9601 devices
+endef
+
+$(eval $(call KernelPackage,usb-net-dm9601-ether))
+
 define KernelPackage/usb-net-cdc-ether
   $(call usbdep,kmod-usb-net @LINUX_2_6)
   TITLE:=Support for cdc ethernet connections