remove uninstalldev templates (no longer necessary)
[openwrt/openwrt.git] / package / keynote / Makefile
index 264f16321938f79c27588554e69c730899a0901f..5b27257b4a74ddb3831210a5fea861f381f3d3af 100644 (file)
@@ -4,65 +4,52 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 4619 2006-08-22 09:50:02Z florian $
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=keynote
 PKG_VERSION:=2.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/
 PKG_MD5SUM:=b569066ac2ba1356c2112b118a7d74d0
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/kernel.mk
 
 define Package/keynote
   SECTION:=net
   CATEGORY:=Network
   DEPENDS:=@LINUX_2_6 +libopenssl
   TITLE:=Simple and flexible trust-management system
-  DESCRIPTION:=\
-       KeyNote is a simple and flexible trust-management system designed to work \\\
-       well for a variety of large- and small- scale Internet-based applications.\\\
-       It provides a single, unified language for both local policies and \\\
-       credentials. 
   URL:=http://www1.cs.columbia.edu/~angelos/keynote.html
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-static \
-               --enable-shared \
-       )
+define Package/keynote/description
+ KeyNote is a simple and flexible trust-management system designed to work 
+ well for a variety of large- and small- scale Internet-based applications.
+ It provides a single, unified language for both local policies and 
+ credentials.
 endef
 
-define Build/Compile
-       $(call Build/Compile/Default, \
-               LIBS="$(EXTRA_LDFLAGS) -L. -lkeynote -lm -lcrypto" \
-       )
-endef
+CONFIGURE_ARGS += \
+       --enable-static \
+       --enable-shared
 
-define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_BUILD_DIR)/{assertion,header,keynote,signature}.h $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_BUILD_DIR)/libkeynote.a $(STAGING_DIR)/usr/lib/
-endef
+MAKE_FLAGS += \
+       CFLAGS="$(TARGET_CFLAGS)"
 
-define Build/UninstallDev
-       rm -rf  $(STAGING_DIR)/usr/include/keynote \
-               $(STAGING_DIR)/usr/lib/libkeynote.a
+define Build/InstallDev
+       mkdir -p $(1)/usr/include/keynote
+       $(CP) $(PKG_BUILD_DIR)/{assertion,header,keynote,signature}.h $(1)/usr/include/keynote/
+       mkdir -p $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/libkeynote.a $(1)/usr/lib/
 endef
 
 define Package/keynote/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/keynote $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/keynote $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,keynote))