remove uninstalldev templates (no longer necessary)
[openwrt/openwrt.git] / package / keynote / Makefile
index 787c19deb7125d6c78496fd89d37f221b2dbbd26..5b27257b4a74ddb3831210a5fea861f381f3d3af 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=keynote
 PKG_VERSION:=2.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/
@@ -23,14 +23,16 @@ define Package/keynote
   CATEGORY:=Network
   DEPENDS:=@LINUX_2_6 +libopenssl
   TITLE:=Simple and flexible trust-management system
-  DESCRIPTION:=\
-       KeyNote is a simple and flexible trust-management system designed to work \\\
-       well for a variety of large- and small- scale Internet-based applications.\\\
-       It provides a single, unified language for both local policies and \\\
-       credentials. 
   URL:=http://www1.cs.columbia.edu/~angelos/keynote.html
 endef
 
+define Package/keynote/description
+ KeyNote is a simple and flexible trust-management system designed to work 
+ well for a variety of large- and small- scale Internet-based applications.
+ It provides a single, unified language for both local policies and 
+ credentials.
+endef
+
 CONFIGURE_ARGS += \
        --enable-static \
        --enable-shared
@@ -39,15 +41,10 @@ MAKE_FLAGS += \
        CFLAGS="$(TARGET_CFLAGS)"
 
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/include/keynote
-       $(CP) $(PKG_BUILD_DIR)/{assertion,header,keynote,signature}.h $(STAGING_DIR)/usr/include/keynote/
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_BUILD_DIR)/libkeynote.a $(STAGING_DIR)/usr/lib/
-endef
-
-define Build/UninstallDev
-       rm -rf  $(STAGING_DIR)/usr/include/keynote \
-               $(STAGING_DIR)/usr/lib/libkeynote.a
+       mkdir -p $(1)/usr/include/keynote
+       $(CP) $(PKG_BUILD_DIR)/{assertion,header,keynote,signature}.h $(1)/usr/include/keynote/
+       mkdir -p $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/libkeynote.a $(1)/usr/lib/
 endef
 
 define Package/keynote/install