change libnl mirror to point to openwrt, original website seems down
[openwrt/openwrt.git] / package / libnl / Makefile
index 9f334108ede8fe30e793b776d8d50cc5579af0c9..d288680ca8baa8459545031151957274a30dd8a7 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,26 +9,28 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libnl
-PKG_VERSION:=1.0-pre7
-PKG_RELEASE:=1
+PKG_VERSION:=1.1
+PKG_RELEASE:=4
 
-PKG_SOURCE:=libnl-1.0-pre7.tar.gz
-PKG_SOURCE_URL:=http://www.suug.ch/~tgr/libnl/files/
-PKG_MD5SUM:=db9f6265c370f09defd2d2fa3540758e
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/
+PKG_MD5SUM:=ae970ccd9144e132b68664f98e7ceeb1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libnl
-  SECTION:=net
-  CATEGORY:=Base system
+  SECTION:=libs
+  CATEGORY:=Libraries
   TITLE:=netlink socket library
-  URL:=http://www.suug.ch/~tgr/libnl/
+  URL:=http://people.suug.ch/~tgr/libnl/
 endef
 
 define Package/libnl/description
  This package contains a library for applications dealing with netlink sockets
 endef
 
+TARGET_CFLAGS += -ffunction-sections $(FPIC)
+
 define Build/Compile
        $(call Build/Compile/Default)
        make -C $(PKG_BUILD_DIR) \
@@ -36,16 +38,18 @@ define Build/Compile
                install
 endef
 
-define Build/InstallDev
+ifneq ($(CONFIG_LINUX_2_6),)
+  define Build/InstallDev
+       $(INSTALL_DIR) $(1)
        $(CP) $(PKG_INSTALL_DIR)/* $(1)/
-endef
+       mkdir -p $(1)/usr/include/libnl
+       $(CP) $(PKG_BUILD_DIR)/include/linux $(1)/usr/include/libnl/
+  endef
 
-define Build/UninstallDev
-endef
-
-define Package/libnl/install
+  define Package/libnl/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/libnl.so.1 $(1)/usr/lib/
-endef
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libnl.so.* $(1)/usr/lib/
+  endef
+endif
 
 $(eval $(call BuildPackage,libnl))