libnl-tiny: remove include/linux overrides to fix various build issues
[openwrt/openwrt.git] / package / libs / libreadline / Makefile
index a9e6a221638f4ec647cebd4c3abb7f23956261be..5b0ca8314d5592ca9a9bca08589ee8b2be5422d4 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -8,17 +8,19 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=readline
-PKG_VERSION:=6.3
+PKG_VERSION:=7.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/readline
-PKG_MD5SUM:=33c8fb279e981274f485fd91da77e94a
+PKG_MD5SUM:=750d437185286f40a369e1e4f4764eda932b9459b5ec9a731628393dd3d32334
 
 PKG_LICENSE:=GPL-3.0
 PKG_LICENSE_FILES:=COPYING
 
 PKG_BUILD_PARALLEL:=1
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,6 +29,7 @@ define Package/libreadline
   CATEGORY:=Libraries
   TITLE:=Command lines edition library
   URL:=http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html
+  ABI_VERSION:=$(PKG_VERSION)
 endef
 
 define Package/libreadline/description
@@ -38,37 +41,32 @@ define Package/libreadline/description
        history expansion on previous commands.
 endef
 
-define Build/Configure
-       $(CP) $(SCRIPT_DIR)/config.guess $(SCRIPT_DIR)/config.sub $(PKG_BUILD_DIR)/support/
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-               --without-curses \
-               bash_cv_wcwidth_broken=no \
-               bash_cv_func_sigsetjmp=yes \
-       )
-endef
+# prevent "autoreconf" from removing "aclocal.m4"
+PKG_REMOVE_FILES:=
+
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
+       --with-curses \
+
+CONFIGURE_VARS += \
+       bash_cv_wcwidth_broken=no \
+       bash_cv_func_sigsetjmp=yes \
 
 TARGET_CPPFLAGS:=-I. -I.. $(TARGET_CPPFLAGS)
 
 TARGET_CFLAGS += $(FPIC)
 
-define Build/Compile
-       $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/readline $(1)/usr/include/
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{history,readline}.{a,so,so.6,so.6.3} $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{history,readline}.{a,so,so.7,so.7.0} $(1)/usr/lib/
 endef
 
 define Package/libreadline/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{history,readline}.{so,so.6,so.6.3} $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{history,readline}.{so,so.7,so.7.0} $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libreadline))