libunwind: update to 1.2
[openwrt/openwrt.git] / package / libs / libunwind / Makefile
index 7d51f7487dd9c83f4f53f70e641d2c7e9de4ce29..ba22664b2875a9af6f139ac68bd67581d3013ea5 100644 (file)
@@ -1,5 +1,6 @@
 #
 # Copyright (C) 2008-2013 OpenWrt.org
+# Copyright (C) 2017 Yousong Zhou <yszhou4tech@gmail.com>
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libunwind
-PKG_VERSION:=1.1
+PKG_VERSION:=1.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SAVANNAH/$(PKG_NAME)
-PKG_HASH:=9dfe0fcae2a866de9d3942c66995e4b460230446887dbdab302d41a8aee8d09a
+PKG_HASH:=1de38ffbdc88bd694d10081865871cd2bfbb02ad8ef9e1606aee18d65532b992
 PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
 
@@ -36,7 +37,10 @@ define Package/libunwind/description
   Libunwind defines a portable and efficient C programming interface (API) to determine the call-chain of a program.
 endef
 
-CONFIGURE_ARGS += --enable-minidebuginfo=no
+CONFIGURE_ARGS += \
+       --disable-documentation \
+       --enable-minidebuginfo=no \
+
 
 define Package/libunwind/install
        $(INSTALL_DIR) $(1)/usr/lib